Bug 39234 - initrd overwritten on boot with CONFIG_2GB
initrd overwritten on boot with CONFIG_2GB
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-05 17:25 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-16 13:05:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-05 17:25:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
hardware = dell poweredge 2450 w/2gb memory.

normal kernel installation procedure for us is to use a initrd
so that the scsi & raid modules may be loaded for the root fs.

recompiled kernel 2.2.19-6.2.1 from the source rpm
via rpm --target=i686 -bb kernel-2.2.spec with
CONFIG_2GB=y (turned off CONFIG_1GB) and installed with
an initrd and lilo.

boot fails saying "initrd overwritten (0x8??????? < 0x8???????) disabling 
it.






How reproducible:
Always

Steps to Reproduce:
recompile kernel with CONFIG_2GB and try to boot with an initrd via lilo.

Additional info:
Comment 1 Need Real Name 2001-05-05 20:23:05 EDT
the actual addresses are (0x80f8e000 < 0x8127f000).
the code which prints this error message is in linux/init/main.c.
Comment 2 Arjan van de Ven 2001-05-06 05:46:31 EDT
What bootloader (lilo?) and what version are you using ?

Why do you want CONFIG_2Gb ?
Comment 3 Need Real Name 2001-05-07 09:52:46 EDT
- as mentioned above i am using lilo (lilo-0.21-15)
- i want config_2gb because i have 2gb of memory in the machine.
Comment 4 Arjan van de Ven 2001-05-08 08:52:58 EDT
For the RH kernel, you don't need CONFIG_2GB for accessing that memory.
Comment 5 Need Real Name 2001-05-09 10:21:28 EDT
apparently i do. running the stock kernel-smp-2.2.19 causes linux to
only use 1GB of physical memory.  

the limitation is due to the way the 32-bit address space is divided: 1GB
kernel and 3GB user space. the kernel can only manage up to 1GB in this
configuration.  turning on CONFIG_2GB paritions the address space into 2GB/2GB.
Comment 6 Arjan van de Ven 2001-05-09 10:54:52 EDT
For > 1Gb systems, running the enterprise kernel is recommended...
Comment 7 Need Real Name 2001-05-09 16:46:25 EDT
right.  i was able to boot to the enterprise kernel and have
the full 2GB recognized.

the problem is that we've seen incompatiblities with the LFS
patch which is also part of the enterprise kernel.  specifically,
we run IBM DB2 apparently does not go through QA under the
"enterprise" kernel.



Comment 8 Arjan van de Ven 2001-05-09 16:55:44 EDT
Ok, I see your point.
I think you need to apply the "linux-2.2.16-bigmem-initrd" patch to your
"non-enterprise" kernel. It is supposed to take care of initrd vs > 1Gb.

The patch can be found in the src.rpm for the kernel, just "rpm -i" it and
the patches are in /usr/src/redhat/SOURCES
Comment 9 Need Real Name 2001-05-14 10:20:20 EDT
is there any way to have future versions of kernel-smp
"work" when the CONFIG_2GB flag is on?  it's much
more maintainable for me to only have to turn on
a flag in the .config versus editing the .spec file
to apply a patch for each kernel release.

thanks.
Comment 10 Arjan van de Ven 2001-05-14 10:28:45 EDT
If the patch worked for you (please confirm), I'll make this patch always apply
for newer versions.

Note You need to log in before you can comment on or make changes to this bug.