Bug 39235 - Kernel doesn't recognize Winbond IO chip and floppy drive doesn't work (+ IDE problems)
Summary: Kernel doesn't recognize Winbond IO chip and floppy drive doesn't work (+ IDE...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i586 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-05 21:51 UTC by Sami Pesonen
Modified: 2008-08-01 16:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 15:38:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and more in debth information about the bug (31.21 KB, text/plain)
2001-05-05 21:55 UTC, Sami Pesonen
no flags Details
system-summary (21.99 KB, text/html)
2001-09-26 07:29 UTC, Need Real Name
no flags Details
/dev/fd0 mount errors (35.79 KB, text/html)
2001-09-26 07:30 UTC, Need Real Name
no flags Details

Description Sami Pesonen 2001-05-05 21:51:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i586; en-US; 0.8.1)
Gecko/20010425

Description of problem:
Kernel doesn't recognize Winbond IO chip and because of that floppy drive
is unmountable. See attached text file for more information (logs and so on).

How reproducible:
Always

Steps to Reproduce:
1. start RH 7.1 Linux on machine with Winbond W83787 IO chip
2. try to: mount /mnt/floppy 
3. see logs
	

Actual Results:  Floppy drive was unreachable/unusable. It works fine when
booting from floppy drive for example Windows rescue floppy
or RH linux instal floppy.

Expected Results:  Mounting would have worked and the user who mounted
floppy drive
could cd /mny/floppy/ and ls and so on.

Additional info:

Linux kernel 2.4.2-2, see attachment for logs.

Comment 1 Sami Pesonen 2001-05-05 21:55:36 UTC
Created attachment 17477 [details]
logs and more in debth information about the bug

Comment 2 Alan Cox 2001-05-19 19:40:45 UTC
PIIX: neither IDE port enabled (BIOS)

is important. The floppy trace looks similar. They appear to be disabled by the
BIOS. Does it have a PNP/nonPNP or DOS/Windows95 bios option you can set to non
plug and play and try ?


Comment 3 Sami Pesonen 2001-05-21 17:39:40 UTC
I checked my bios settings and yes there is PNP setting, but it is off.
There is also PCI/PNP or ISA/EISA setting for every IRQ but I'm not sure
is it related.

I had Redhat 7.0 installed earlier in my machine and it worked OK
and I can remember that there were these same lines
PIIX: neither IDE port enabled (BIOS) and so on.


Comment 4 Sami Pesonen 2001-07-15 21:19:37 UTC
I tested rebooting whithout "ide=nodma" append text and
it stopped like this:

Partition check:
 hda: hda1 hda2 < hda5 hda6 hda7 hda8 hda9 hda10 hda11 >
 hdb: hdb1 hdb2 hdb4 < hdb5 hdb6 hdb7 >
 hdd: hdd: chipset supported ide dma timeout func only: 14
hdd: status error: status=0x58 { DriveReady SeekComplete DataRequest }

I wrote it down to paper so there might be some typos...
When I was first time installing RH 7.1 it stopped like this.

I checked my cdrom model to get it to DMA black list:

[spesonen@haisuli ~]$ cat /proc/ide/hdc/model 
TOSHIBA CD-ROM XM-6402B

Here are other ide drives:

[spesonen@haisuli ~]$ cat /proc/ide/hda/model 
QUANTUM FIREBALL EL10.2A
[spesonen@haisuli ~]$ cat /proc/ide/hdb/model 
ST31220A
[spesonen@haisuli ~]$ cat /proc/ide/hdd/model 
ST5850A

BR,
Sami

Comment 5 Need Real Name 2001-09-18 10:09:27 UTC
I am a newbie. I have the same problem and the same error messages.
(RHL 7.1 Pentium 200 )

I have installed the latest kernel (2.4.3-12.i586.rpm)... but I still
can't mount dev/fd0.

What can I try more ?


Comment 6 Alan Cox 2001-09-18 13:03:42 UTC
Please attach a copy of the messages you get at boot and when you try this


Comment 7 Need Real Name 2001-09-26 07:29:23 UTC
Created attachment 32618 [details]
system-summary

Comment 8 Need Real Name 2001-09-26 07:30:43 UTC
Created attachment 32619 [details]
/dev/fd0 mount errors

Comment 9 Bugzilla owner 2004-09-30 15:38:59 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.