Bug 39239 - kerhel.h construction fragile
Summary: kerhel.h construction fragile
Status: CLOSED DUPLICATE of bug 36480
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-06 00:40 UTC by D. Hugh Redelmeier
Modified: 2014-03-17 02:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 13:53:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description D. Hugh Redelmeier 2001-05-06 00:40:18 UTC
I am using Red Hat's 2.2.19 kernel source package to build custom kernels
under RHL 7.0.  The builds get a lot of error messages because
/boot/kernel.h and aliases are malformed.
This file is built by fragile code in /etc/rc.d/rc.sysinit, from line 587
on.  The core of the problem is that the code tries to use the output of
"uname -r", and this is changed when I edit EXTRAVERSION in the kernel
Makefile.
This script really needs to be rethought.
Sample lines from my /boot/kernel.h:
	#ifndef __MODULE_KERNEL_package kernel2.2.19-7.0.1fs-2.2.19-7.0.1fs is not
installed
	#define __MODULE_KERNEL_package kernel2.2.19-7.0.1fs-2.2.19-7.0.1fs is not
installed 1

uname -r yields:
	2.2.19-7.0.1fs


Comment 1 Arjan van de Ven 2001-05-06 09:47:52 UTC
Said script is part of the initscripts package

Comment 2 Bill Nottingham 2001-05-07 13:53:15 UTC

*** This bug has been marked as a duplicate of 36558 ***

Comment 3 Bill Nottingham 2001-05-07 13:53:53 UTC

*** This bug has been marked as a duplicate of 36480 ***


Note You need to log in before you can comment on or make changes to this bug.