Bug 392391 - %pre scriptlet failed when installing virt-manager
%pre scriptlet failed when installing virt-manager
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 09:11 EST by Alexander Todorov
Modified: 2008-04-04 10:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 10:54:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2007-11-20 09:11:11 EST
Description of problem:
'yum install virt-manager' fails with %pre scriptlet error.

Version-Release number of selected component (if applicable):
virt-manager-0.5.2-2.fc8


How reproducible:
Always

Steps to Reproduce:
1. Install & update a Fedora 8 distribution
2. yum install virt-manager

  
Actual results:
Downloading Packages:
(1/1): virt-manager-0.5.2 100% |=========================| 1.2 MB    00:01     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
error:   install: %pre scriptlet failed (2), skipping virt-manager-0.5.2-2.fc8

Installed: virt-manager.x86_64 0:0.5.2-2.fc8
Complete!


Expected results:
Package installs without error.

Additional info:
Previously running the same command installed all other dependencies and failed
for virt-manager package. Although there is an error yum shows that the package
is installed.

$ rpm -qa | grep virt
virt-viewer-0.0.2-2.fc8
libvirt-python-0.3.3-2.fc8
python-virtinst-0.300.1-3.fc8
libvirt-0.3.3-2.fc8

virt-manager is not installed.

The host machine is a Xen paravirtual guest running on RHEL 5.1. Everything else
works fine. 

NOTE: Running virtualization layer on top of already virtualized system will
lead to poor performance but that should not be a reason for the package to install.
Comment 1 Alexander Todorov 2007-11-22 06:52:45 EST
Interesting thing is that today I managed to install the same version
virt-manager without any problems. I only upgraded this morning to the latest F8
updates.
Comment 2 Daniel Berrange 2008-04-04 10:54:58 EDT
THis doesn't appear to be reproducable - I can only assume a transient fault
with your GConf install, since that's all that virt-manager runs in %pre & we
have a correct Requires(pre): GConf2 already.

Note You need to log in before you can comment on or make changes to this bug.