Bug 392471 - Incorrect error description for non-existent interfaces in connect(2)
Incorrect error description for non-existent interfaces in connect(2)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: man-pages-ja (Show other bugs)
4.0
All Linux
low Severity low
: ---
: ---
Assigned To: Akira TAGOH
QE Internationalization Bugs
:
Depends On:
Blocks: 409961
  Show dependency treegraph
 
Reported: 2007-11-20 09:43 EST by Adam Stokes
Modified: 2010-10-22 16:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 07:32:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correct man page (870 bytes, patch)
2007-11-20 09:43 EST, Adam Stokes
no flags Details | Diff

  None (edit)
Description Adam Stokes 2007-11-20 09:43:38 EST
Description of problem:
The man page of connect(2) says that,
 "EAGAIN
     No more free local ports or insufficient entries in the routing cache."
 
 However, the present system returns "EADDRNOTAVAIL" at the above-mentioned
 errors.

Version-Release number of selected component (if applicable):
man-pages-ja-1.67-14

How reproducible:
Always

Steps to Reproduce:
1. man 2 connect
  
Actual results:
Describes EAGAIN

Expected results:
Should describe EADDRNOTAVAIL

Additional info:
Comment 1 Adam Stokes 2007-11-20 09:43:38 EST
Created attachment 264951 [details]
patch to correct man page
Comment 5 RHEL Product and Program Management 2008-01-18 08:37:57 EST
This bugzilla was reviewed by QE as a non-FasTrack request.
It has since been proposed for FasTrack. The qa_ack has 
been reset. QE needs to re-review this bugzilla for FasTrack.
Comment 12 Akira TAGOH 2008-11-12 23:59:55 EST
Fixed in man-pages-ja-20050215-3.el4.
Comment 16 errata-xmlrpc 2008-12-03 07:32:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-1000.html

Note You need to log in before you can comment on or make changes to this bug.