Bug 39248 - swap requirements too mechanical
Summary: swap requirements too mechanical
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: alpha Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-06 06:34 UTC by Michal Jaegermann
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 15:52:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2001-05-06 06:34:46 UTC
Description of Problem:

I happen to have on a test machine 449 MB of a swap space scattered
over different disks.  Still anaconda wants an extra 31 MB of a swap
file because I happend to have 256 MB of memory installed.  Common
guys!  There have to be some reasonable limit when even this broken
Python does not swap anymore.  Yes, I am aware of problems with
swap in current 2.4 kernels but if you look closer at what was said
on linux-kernel list than this is not exactly a "twice memory" mechanical
requirement.  You may need that when you start really swapping
but below that a behaviour is not really different from 2.2 kernels.

Note that I was able to install at least something (see #39244) when
I _reduced_ an amount of a swap space as opposed to working with a full
complement.

  Michal
  michal@harddata.com

Comment 1 Brent Fox 2001-05-07 15:51:58 UTC
The "reasonable limit" is 1 Gig of ram.  Above that, we don't require 2x ram for
the swap.  Maybe that's too high, maybe it's too low...but that's where we made
it.  It's hard to come up with a level that would please everybody.


Note You need to log in before you can comment on or make changes to this bug.