Bug 392511 - 1280x1024 resolution shown as not available, but worked in FC6
Summary: 1280x1024 resolution shown as not available, but worked in FC6
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nv (Show other bugs)
(Show other bugs)
Version: 8
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-20 15:06 UTC by Tim Wegener
Modified: 2011-08-12 20:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 16:12:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (oldest) (48.18 KB, text/plain)
2007-11-20 15:06 UTC, Tim Wegener
no flags Details
Xorg log (older) (48.17 KB, text/plain)
2007-11-20 15:07 UTC, Tim Wegener
no flags Details
Xorg log (recent) (48.17 KB, text/plain)
2007-11-20 15:08 UTC, Tim Wegener
no flags Details
xorg.conf with manually added Modes line (754 bytes, text/plain)
2007-11-20 15:11 UTC, Tim Wegener
no flags Details

Description Tim Wegener 2007-11-20 15:06:27 UTC
Description of problem:
Highest resolution is detected as 1280x960 and this is the resolution that gets
used by default.
Note that the auto-generated xorg.conf had no Modes line. 
Adding a modes line that included 1280x1024 and restarting X made that
resolution available again. 

Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-2.1.5-2.fc8
xorg-x11-drivers-7.2-9.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora 8
2. system-config-display
3. Click on 'Resolution' and notice that highest is 1280x960
  
Actual results:
Highest resolution is detected as 1280x960 and this is the resolution that gets
used by default.

Expected results:
Highest resolution should be 1280x1024 and used by default.

Additional info:
ViewSonic E771 monitor
nVidia GeForce2 MX400 video card (NV11)
Worked fine in Fedora Core 6

Comment 1 Tim Wegener 2007-11-20 15:06:27 UTC
Created attachment 264981 [details]
xorg log file (oldest)

Comment 2 Tim Wegener 2007-11-20 15:07:37 UTC
Created attachment 264991 [details]
Xorg log (older)

Comment 3 Tim Wegener 2007-11-20 15:08:46 UTC
Created attachment 265001 [details]
Xorg log (recent)

Comment 4 Tim Wegener 2007-11-20 15:11:07 UTC
Created attachment 265021 [details]
xorg.conf with manually added Modes line

Note that the only difference between this and the original auto-generated
xorg.conf file is the manually added Modes line.

Comment 5 Adam Jackson 2008-02-12 16:12:48 UTC
All of those log files show 1280x1024 being selected.

But, that said, I know what behaviour you're seeing here, and it's intentional.
 The monitor reports a 4:3 physical size, so we pick the largest 4:3 video mode
that it claims to support, because non-square pixels are evil.

Comment 6 Tim Wegener 2008-03-09 11:05:43 UTC
I can't explain the log files, but all I know is that I was unable to select
1280x1024 resolution without modifying xorg.conf by hand. 

I really do not care whether or not my pixels are not perfectly square. They
look fine to me in 1280x1024 mode. I am much more concerned out maximizing
screen real estate and using my hardware capabilities to the fullest rather than
subtleties of pixel shape. 

At the very least, shouldn't I be able to select this resolution from the GUI,
rather than having to hand edit config files? 

I humbly implore you to reopen this bug.



Note You need to log in before you can comment on or make changes to this bug.