Bug 392561 - ath5k driver does not work with AR5005G 802.11abg NIC (PCI)
Summary: ath5k driver does not work with AR5005G 802.11abg NIC (PCI)
Status: CLOSED DUPLICATE of bug 254192
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 8
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-20 15:27 UTC by Tim Wegener
Modified: 2008-01-24 20:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 20:09:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Wegener 2007-11-20 15:27:04 UTC
Description of problem:
It appears to detect the card correctly and automatically sets up the ath5k
driver. However, it doesn't associate with the access point. Using
NetworkManager provides no success.
The livna madwifi driver works fine (after blacklisting ath5k), with
NetworkManager and WPA. 

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-49.fc8 (i686)

How reproducible:
Always.

Steps to Reproduce:
1. Start NetworkManager
2. Try to make a wireless connection.
  
Actual results:
Can't make a connection.

Expected results:
Detect access points, prompt for WPA passphrase and successfully connect.

Additional info:

dmesg:
usbcore: registered new interface driver hci_usb
PCI: Found IRQ 11 for device 0000:00:11.0
PCI: Sharing IRQ 11 with 0000:00:07.2
PCI: Sharing IRQ 11 with 0000:00:09.0
PCI: Sharing IRQ 11 with 0000:00:0d.2
phy0: Selected rate control algorithm 'simple'
ath5k_pci 0000:00:11.0: Atheros AR5213A chip found: MAC 0x78, PHY: 0x45
ath5k_pci 0000:00:11.0: RF2112A radio found (0x56)
PCI: Found IRQ 10 for device 0000:00:0b.0
PCI: Sharing IRQ 10 with 0000:00:0d.1
usbcore: registered new interface driver snd-usb-audio

...

ath: can't set the key


lspci:
00:11.0 Ethernet controller: Atheros Communications, Inc. AR5005G 802.11abg NIC
(rev 01)


ip link show dev wlan0:
4: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:13:46:93:8c:a6 brd ff:ff:ff:ff:ff:ff

ip address show dev wlan0
4: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:13:46:93:8c:a6 brd ff:ff:ff:ff:ff:ff

Comment 1 John W. Linville 2007-11-29 14:50:54 UTC
Lots of ath5k updates in kernel-2.6.23.8-63.fc8...does that work any better 
for you?

Comment 2 Tim Wegener 2007-12-03 10:38:12 UTC
No, still not working with kernel-2.6.23.8-63.fc8.

dmesg:
usbcore: registered new interface driver hci_usb
phy0: Selected rate control algorithm 'simple'
ath5k_pci 0000:00:11.0: Atheros AR5213A chip found (MAC: 0x78, PHY: 0x45)
ath5k_pci 0000:00:11.0: RF2112A 2GHz radio found (0x56)
PCI: Found IRQ 10 for device 0000:00:0b.0
PCI: Sharing IRQ 10 with 0000:00:0d.1
usbcore: registered new interface driver snd-usb-audio
...
ADDRCONF(NETDEV_UP): wlan0: link is not ready
...
ADDRCONF(NETDEV_UP): wlan0: link is not ready
kjournald starting.  Commit interval 5 seconds


Comment 3 Christopher Brown 2008-01-23 23:42:14 UTC
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Comment 4 John W. Linville 2008-01-24 20:09:06 UTC

*** This bug has been marked as a duplicate of 254192 ***


Note You need to log in before you can comment on or make changes to this bug.