Bug 392641 - gstreamer-engine is missing in amarok
gstreamer-engine is missing in amarok
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 10:52 EST by Lev Shamardin
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 11:01:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lev Shamardin 2007-11-20 10:52:39 EST
Description of problem:
The gstreamer engine for amarok is missing.

How reproducible:
always.

Steps to Reproduce:
1. su -c "yum -y install amarok"
2. amarok &
3. check the engines list in the Settings->Configure Amarok->Engine->Sound System
  
Actual results:
The resulting list of engines does not contain gstreamer engine.

Expected results:
The gstreamer engine should be in the list.

Additional info:
The spec file of the RPM shows that all sections regarding the gstreamer engine
are commented out with no particular explanations in comments given, but the
%configure command still includes the --with-gstreamer10 argument.
Comment 1 Rex Dieter 2007-11-20 10:58:08 EST
Last I knew, upstream amarok no longer included/supported the gstreamer engine
(still under development).  I'll go double-check if my recollection is correct...
Comment 2 Rex Dieter 2007-11-20 11:01:15 EST
Yep,
http://amarok.kde.org/blog/archives/91-Backends,-Phonon,-GStreamer.html
"... So a few days ago, amaroK's gstreamer engine was turned off - the Xine and
Helix backends are fine..."

I 'spose we could/should remove the references to gst in the specfile then. :)
Comment 3 Lev Shamardin 2007-11-20 11:02:27 EST
If it is not supported could you please notice this in the %changelog or in the
comments of the spec file?
Comment 4 Rex Dieter 2007-11-20 14:02:10 EST
ok

Note You need to log in before you can comment on or make changes to this bug.