Bug 392681 - jwhois doesn't allways work with certain servers when IPv4 is in use
jwhois doesn't allways work with certain servers when IPv4 is in use
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jwhois (Show other bugs)
8
All Linux
high Severity high
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 11:41 EST by Lubomir Kundrak
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 07:08:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for the jwhois IPv4 connect issue (2.87 KB, patch)
2007-11-20 11:41 EST, Lubomir Kundrak
no flags Details | Diff

  None (edit)
Description Lubomir Kundrak 2007-11-20 11:41:48 EST
Description of problem:

In case the WHOIS server has both A and AAAA/A6 DNS records (such as the default
one, whois.ripe.net) and IPv6 connection is not available, jwhois will fail to
connect due to broken logic of iterating through available addresses.  

Version-Release number of selected component (if applicable):

jwhois-4.0-3.fc8

How reproducible:

Always

Steps to Reproduce:
1. $ whois netbsd.sk
  
Actual results:

[Querying whois.ripe.net]
[Unable to connect to remote host]

Expected results:

[Querying whois.ripe.net]
[whois.ripe.net]
% This is the RIPE Whois query server #2.
% The objects are in RPSL format.
%
% Rights restricted by copyright.
% See http://www.ripe.net/db/copyright.html

% The object shown below is NOT in the RIPE database.
% It has been obtained by querying a remote server:
% (whois.sk-nic.sk) at port 43.
% To see the object stored in the RIPE database
% use the -R flag in your query
%
%REFERRAL START
%
% whois.sk-nic.sk - whois server for TLD .sk
%


Domain-name         netbsd.sk
Admin-id            MICH-0738
Admin-name          Michal Fabry
Admin-legal-form    zivnost
Admin-address       Nobelova 46, Bratislava 83102
Admin-telephone     0904851151, , 0904851151
Admin-email         michal.fabry@hladat.sk
Tech-id             MICH-0738
Tech-name           Michal Fabry
Tech-address        Nobelova 46, Bratislava 83102
Tech-telephone      0904851151, , 0904851151
Tech-email          michal.fabry@hladat.sk
dns_name            ns1.figisoft.sk
dns_name            ns2.figisoft.sk
Last-update         2007-04-17
Valid-date          2008-04-29
Domain-status       DOM_OK

%%REFERRAL END

Additional info:

The fix is attached.
Is there any good reason the package does not have cvsextras commits enabled?
Comment 1 Lubomir Kundrak 2007-11-20 11:41:48 EST
Created attachment 265091 [details]
Fix for the jwhois IPv4 connect issue

Note You need to log in before you can comment on or make changes to this bug.