Bug 392701 - module-init-tools fails to process directories named "weak-updates"
module-init-tools fails to process directories named "weak-updates"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: module-init-tools (Show other bugs)
4.6
All Linux
urgent Severity low
: rc
: ---
Assigned To: Jon Masters
GSSApproved
: ZStream
Depends On:
Blocks: 411991
  Show dependency treegraph
 
Reported: 2007-11-20 11:53 EST by Jon Masters
Modified: 2008-07-24 15:48 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0756
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:48:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
module-init-tools-limited-weak-updates.patch (474 bytes, text/x-patch)
2007-11-20 11:53 EST, Jon Masters
no flags Details

  None (edit)
Description Jon Masters 2007-11-20 11:53:28 EST
Description of problem:

A bug exists in the is_update() logic present within the module-init-tools
module processing source code, which will result in any kernel module directory
containing the word "updates" being ignored, unless it is called exactly
"updates". This (old, now gone) upstream behavior is sufficient in RHEL4,
because, normally, modules are never in directories so named.

In the case of xenpv drivers, these are contained within a directory called
"weak-updates", which needs to be parsed. A simple check is sufficient in order
to ensure that such a directory is not ignored during parsing of all of the
modules present on a given system for symbol versioning and the generation of
the modules.dep file(s).

Version-Release number of selected component (if applicable):

3.1-0.pre5.3.4

How reproducible:

Every time.

Steps to Reproduce:
1. Install driver updates on RHEL4 system
2. Drivers in weak-updates are ignored
3.
  
Actual results:

Xen PV drivers are not added to module database

Expected results:

Xen PV drivers ARE added to module database

Additional info:

A fix has been tested, patch is attached.
Comment 1 Jon Masters 2007-11-20 11:53:28 EST
Created attachment 265111 [details]
module-init-tools-limited-weak-updates.patch
Comment 12 errata-xmlrpc 2008-07-24 15:48:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0756.html

Note You need to log in before you can comment on or make changes to this bug.