This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 392721 - Via Rhine II intermittent eth0 interface failure (similar to bug 377721)
Via Rhine II intermittent eth0 interface failure (similar to bug 377721)
Status: CLOSED DUPLICATE of bug 377721
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 12:02 EST by David Betz
Modified: 2008-02-13 18:25 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 18:25:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Smolt profile of affected machine (9.09 KB, text/plain)
2007-11-20 12:02 EST, David Betz
no flags Details

  None (edit)
Description David Betz 2007-11-20 12:02:12 EST
Description of problem:
Ethernet device stops working after use

Version-Release number of selected component (if applicable):
Fedora 8 base install

How reproducible:
always

Steps to Reproduce:
1. Install Fedora 8
2. Transfer a large file by ssh/tar from a locally connected host.

Actual results:
Transfer hangs after a few seconds. User is unable to complete transfer. Locally
connected hosts can no longer be pinged. Interface is non-functional. 
Functioning interface may be temporarily restored by /sbin/ifdown eth0 ;
/sbin/ifup eth0.

Expected results:
Transfer completes, interface remains functional

Additional info:

I stumbled across this bug doing fresh install of Fedora 8.  I tried both the
i386 install and the x86_64 install.  On the x86 install, I tried both the i686
and i586 kernels.  I tried various boot parameters:

noapic -> causes machine to slow to a crawl - one must even type slowly or else
typed input is dropped.
pci=routeirq
acpi=off
pci=noacpi
acpi=noirq -> none of these settings fixed the problem.

When the eth0 device fails, the following messages appear in /var/log/messages:
NETDEV WATCHDOG: eth0: transmit timed out
eth0: Transmit timed out, status 0003, PHY status 786d, resetting ...
eth0: link up, 100Mbps, full duplex, lpa 0x45E1

Interestingly, when I use the install disk in rescue mode, the interface
functions normally - I can transfer large files without the interface hanging.

This bug/behavior is not present on a fresh Fedora Core 7 install.  FC7
functions normally and I am able to transfer large files.
Comment 1 David Betz 2007-11-20 12:02:12 EST
Created attachment 265121 [details]
Smolt profile of affected machine
Comment 2 Hans de Goede 2008-01-14 04:01:33 EST
Intro: I'm a Fedora contributer doing some kernel bug triaging. Like you already
say yourself, this seems a dup of bug 377721, is there any particular reason why
you're filing this as a separate bug?

If not please close this one as a dup of 377721.
Comment 3 Christopher Brown 2008-02-13 18:25:28 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am closing this as a duplicate as indicated in comment #2.

*** This bug has been marked as a duplicate of 377721 ***

Note You need to log in before you can comment on or make changes to this bug.