Bug 392821 - samba init script does not start nmbd daemon
samba init script does not start nmbd daemon
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 13:50 EST by adam williams
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-22 17:30:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description adam williams 2007-11-20 13:50:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.1; .NET CLR 3.0.04506.30)

Description of problem:
/etc/rc.d/init.d/smb start does not start the nmbd daemon which is used by samba for WINS resolution of host names.  So Windows clients can not connect to samba primary domain controllers that use wins support = yes in /etc/samba/smb.conf



Version-Release number of selected component (if applicable):
samba-3.0.26a-6.fc8

How reproducible:
Always


Steps to Reproduce:
[root@missioncontrol ~]# rpm -qa|grep samba
samba-client-3.0.26a-6.fc8
samba-3.0.26a-6.fc8
samba-common-3.0.26a-6.fc8
[root@missioncontrol ~]# /etc/rc.d/init.d/smb start
Starting SMB services:                                     [  OK  ]
[root@missioncontrol ~]# ps ax|grep nmb
22018 pts/0    S+     0:00 grep nmb
[root@missioncontrol ~]# cat /etc/rc.d/init.d/smb |grep nmb
[root@missioncontrol ~]#
[root@missioncontrol ~]# nmblookup -M NOTWISE-LABS
added interface ip=10.1.3.1 bcast=10.1.3.255 nmask=255.255.255.0
added interface ip=127.0.0.1 bcast=127.255.255.255 nmask=255.0.0.0
querying NOTWISE-LABS on 10.1.3.255
querying NOTWISE-LABS on 127.255.255.255
name_query failed to find name NOTWISE-LABS#1d
[root@missioncontrol ~]# cat /etc/samba/smb.conf|grep NOTWISE-LABS
   workgroup = NOTWISE-LABS
[root@missioncontrol ~]# rpm -qf /usr/bin/nmblookup
samba-client-3.0.26a-6.fc8
[root@missioncontrol ~]# /usr/sbin/nmbd -D
[root@missioncontrol ~]# ps ax|grep nmbd
22260 ?        Ss     0:00 nmbd -D
22261 ?        S      0:00 nmbd -D
[root@missioncontrol ~]# nmblookup -M NOTWISE-LABS
added interface ip=10.1.3.1 bcast=10.1.3.255 nmask=255.255.255.0
added interface ip=127.0.0.1 bcast=127.255.255.255 nmask=255.0.0.0
querying NOTWISE-LABS on 10.1.3.255
Got a positive name query response from 10.1.3.1 ( 10.1.3.1 )
10.1.3.1 NOTWISE-LABS<1d>


Actual Results:
WINS reslution does not work unless nmbd -D is started manually because it is not in the init script even though the command to start nmbd was in previous versions of the samba init script.

Expected Results:
nmbd -D should be included to start in /etc/rc.d/init.d/smb start

Additional info:
[root@missioncontrol ~]# cat /etc/redhat-release
Fedora release 8 (Werewolf)
[root@missioncontrol ~]# free -ot
             total       used       free     shared    buffers     cached
Mem:        254308     218844      35464          0      26172      78204
Swap:       136512      43964      92548
Total:      390820     262808     128012
[root@missioncontrol ~]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 6
cpu MHz         : 935.481
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36 mmx fxsr sse up
bogomips        : 1871.83
clflush size    : 32

[root@missioncontrol ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2              19G   14G  3.8G  80% /
none                  125M     0  125M   0% /dev/shm
/dev/sdb1              19G   18G  7.0M 100% /mnt/hdb1
/dev/sdc1             9.3G  7.0G  1.9G  80% /home/kameleon
//adam/c               29G   29G  131M 100% /home/adam/c
/home/kameleon/Fedora-8-i386-DVD.iso
                      3.2G  3.2G     0 100% /mnt/cdrom
//10.1.3.225/d         75G   53G   22G  71% /home/adam/d
Comment 1 Simo Sorce 2007-11-22 17:30:41 EST
the init script for nmbd is /etc/init.d/nmb

Note You need to log in before you can comment on or make changes to this bug.