Bug 39283 - rpm.error: match tag missing in new header
rpm.error: match tag missing in new header
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-06 15:08 EDT by Stefan Bauch
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-10 17:56:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda complete dump (9.82 KB, text/plain)
2001-05-06 15:10 EDT, Stefan Bauch
no flags Details

  None (edit)
Description Stefan Bauch 2001-05-06 15:08:25 EDT
Description of Problem:
After 2 years of continous upgrading I decided that Kernel 2.4 is the right moment for a fresh
install. After wiping my root- and /usr partitions of RH 7.0 the installer died with above message.
Thank god, I still have my OS/2 Warp around for this submission...

I wonder what makes my install so special. Is my CD-R corrupt???

Steps to Reproduce:
1. Boot from CD (GUI or Text, no difference)
2. select custom install, select packages
3. select video card and monitor, test works flawlessly
4. format / and /usr, leave /home and /mnt/data untouched
5. package progress-dialog pops up
6. Following Message appears (complete lo attached)
Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
    rc = apply (step[1](), args)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/textw/upgrade_text.py", line 33, in __call__
    todo.upgradeFindPackages ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1224, in upgradeFindPackages
    self.method.mergeFullHeaders(self.hdList)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/image.py", line 26, in mergeFullHeaders
    hdlist.mergeFullHeaders(self.tree + "/RedHat/base/hdlist2")
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/comps.py", line 123, in mergeFullHeaders
    rpm.mergeHeaderListFromFD(self.hdlist, fd, 1000004)
rpm.error: match tag missing in new header

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 8273ba0>
file: /mnt/source/RedHat/base/hdlist2
fd: 7


Additional Information:

Hardware
AMD K6-2 400Mhz
128 MB RAM
OS/2 Boot-Manager in MBR, DOS and OS/2 Partition
SCSI cdrom and HD (IBM, 9.2 GB) (Adaptec AIC78U2 Controller)
ATI AGP 4MB
Soundcard: Philips OPL3SA
TV: BT 878 (TerraTec)
Comment 1 Stefan Bauch 2001-05-06 15:10:00 EDT
Created attachment 17506 [details]
Anaconda complete  dump
Comment 2 Stefan Bauch 2001-05-06 15:42:23 EDT
Found bug # 39069 after broader search which looks similar, but I don't understand why it should be a duplicate of #37996 which does not look like 
the problem I have. I am doing a CD-ROM install, not HD, so the solution of #37996 seems not meaningful to me. I don't understand how it should 
have helped the user of #39069. 

PS: I can't access my regular mail-account due to the lack of my beloved Linux, so please direct any mail to stefan.bauch@epost.de. I don't want to 
register under this username with bugzilla and I can't CC there otherwise...
Comment 3 Stefan Bauch 2001-05-07 09:31:10 EDT
I contacted the person I received the CD-R from and he confirmed that
there was a problem in the mastering. Please defer this issue until I 
receive a new set of CD and re-install with them. 
Comment 4 Stefan Bauch 2001-05-21 09:46:51 EDT
Has been proven a media/mastering problem.
Comment 5 Jeremy Katz 2001-09-10 17:57:11 EDT
Media problem.

Note You need to log in before you can comment on or make changes to this bug.