Bug 392861 - Update to mutt-1.5.17-1.fc7 broke mutt setting From:
Update to mutt-1.5.17-1.fc7 broke mutt setting From:
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 14:27 EST by Tom Chiverton
Modified: 2007-12-06 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.5.17-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 12:40:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Chiverton 2007-11-20 14:27:21 EST
On my Fedora Core 7, x86_64 box, I have a daily job that emails some things 
off site:
# mutt -F /root/.muttrc -a /tmp/cacti.sql -s'back cacti' t@g.com < /dev/null

The .muttrc is:
# cat /root/.muttrc
set from="root <root@mydemain.com>"
#            

Up until the day I applied 
https://www.redhat.com/archives/fedora-package-announce/2007-November/msg00490.html 
this worked fine.

Now it is leaving the From: as 'root@hostname.localhost', which isn't in 
public DNS, so my upstream SMTP smart host rejects it.

I have strace'd mutt, and it's differently sending the wrong thing to the 
local sendmail, and as I said, it worked until the recent update.

Just to confirm, downgrading to mutt-1.5.14-3.fc7.x86_64 (with --oldpackage, 
having --force'd the removal of 'urlview') has fixed the problem.
rpm moaned about creating Muttrc as Muttrc.rpmnew, but the diff of the two 
doesn't indicate anything that looks like it should cause this.
Comment 1 Tom Chiverton 2007-11-21 13:35:58 EST
set use_envelope_from
set envelope_from_address="..."

One of those two does the trick and returns things to working order.
Comment 2 Miroslav Lichvar 2007-11-23 06:58:45 EST
Should be fixed in mutt-1.5.17-2.fc7.

Thanks for the report.
Comment 3 Fedora Update System 2007-11-26 13:39:59 EST
mutt-1.5.17-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mutt'
Comment 4 Fedora Update System 2007-11-26 13:48:04 EST
mutt-1.5.17-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mutt'
Comment 5 Tom Chiverton 2007-11-27 14:15:28 EST
That's fixed it here (FC7).
My original .muttrc works fine (below)
# cat .muttrc
set from="root <root@mydomain.com>"
set use_from=yes
set envelope_from=yes
#      
Comment 6 Fedora Update System 2007-12-06 12:40:16 EST
mutt-1.5.17-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2007-12-06 17:50:17 EST
mutt-1.5.17-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.