Bug 39289 - rc.sysinit welcomes system crackers
Summary: rc.sysinit welcomes system crackers
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-06 22:34 UTC by Landon Curt Noll
Modified: 2014-03-17 02:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 15:19:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Landon Curt Noll 2001-05-06 22:34:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.17-14 i686)

Description of problem:
The rc.sysinit script prints "Welcome to Red Hat".

While this may be friendly, it does make problems for folks who charge a
system
cracker with ``breaking and entering'' a system.  This welcome message made
it
a bit harder to press charges because the defense claimed that the system
had welcomed the system cracker.

How reproducible:
Always

Steps to Reproduce:
1.reboot
2.Notice the welcome message
3.
	

Actual Results:  The system welcomed you.

Expected Results:  Perhaps it should say something like, ``This is Red
Hat'' instead?

Additional info:

Try:

*** rc.sysinit.init	Sun May  6 14:49:19 2001
--- rc.sysinit	Sun May  6 14:49:19 2001
***************
*** 34,40 ****
  . /etc/init.d/functions
  
  # Print a banner. ;)
! echo -en "\t\t\tWelcome to "
  [ "$BOOTUP" != "serial" ] && echo -en "\\033[1;31m"
  echo -en "Red Hat"
  [ "$BOOTUP" != "serial" ] && echo -en "\\033[0;39m"
--- 34,40 ----
  . /etc/init.d/functions
  
  # Print a banner. ;)
! echo -en "\t\t\tThis is "
  [ "$BOOTUP" != "serial" ] && echo -en "\\033[1;31m"
  echo -en "Red Hat"
  [ "$BOOTUP" != "serial" ] && echo -en "\\033[0;39m"

Comment 1 Daniel Roesen 2001-05-07 12:55:23 UTC
Interesting comment. IANAL, but I also heard that.

Comment 2 Alan Cox 2001-05-19 20:22:48 UTC
I've also heard it - but as an Urban Legend. An actual legal cite would be more
useful


Comment 3 Landon Curt Noll 2001-06-02 07:27:58 UTC
Speaking personally, there is no legal site.  It never went to trial.

While you may think of it has an urband legend, the welcome
argument issue was raised.  We will never know if the it would
have stood up in court because it never went to trial.

To be in the safe side, we changed all of our systems to not
"Welcome".   It is simple enough to side-step the entire issue,
by changing the welcome to a simple "This is Redhat" or
"RedHat 7.x starting" or "Powered by RedHat" or "RedHat 7.x"
or something ...

Comment 4 kop 2002-07-10 15:37:00 UTC
So, make the welcome messsage configurable.

"Welcome to Redhat, unless you're a cracker or a lawyer."

Comment 5 Leonard den Ottolander 2004-02-05 12:34:04 UTC
This bug report is nonsense and should be closed NOTABUG, or WONTFIX
at worst.

If I have a doormat that says "Welcome" I do not invite burglars into
my house. This is an obvious fact even if a lawyer might state (not
think/believe) otherwise.



Note You need to log in before you can comment on or make changes to this bug.