Bug 393051 - Libvirt fails to bring up bridging with rawhide kernel
Libvirt fails to bring up bridging with rawhide kernel
Status: CLOSED DUPLICATE of bug 390991
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 15:53 EST by James Morris
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 16:08:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Morris 2007-11-20 15:53:43 EST
Description of problem:


Version-Release number of selected component (if applicable):

libvirt-0.3.3-2.fc8
kernel-2.6.24-0.39.rc3.git1.fc9

How reproducible:

Always

Steps to Reproduce:

# libvirtd --verbose
libvir: QEMU error : failed to bring the bridge 'virbr0' up : Invalid argument
Failed to autostart network 'default': failed to bring the bridge 'virbr0' up :
Invalid argument

Additional info:

It appears to be specific to recent upstream kernels.

The EINVAL is being returned via
117  ioctl(7, SIOCSIFADDR, 0x7fff4e862d60) = 0
5117  ioctl(7, SIOCSIFNETMASK, 0x7fff4e862d60) = 0
5117  ioctl(7, SIOCGIFFLAGS, {ifr_name="virbr0",
ifr_flags=IFF_BROADCAST|IFF_MULTICAST}) = 0
5117  ioctl(7, SIOCSIFFLAGS, 0x7fff4e862d70) = -1 EINVAL (Invalid argument)
5117  write(2, "libvir: QEMU error : failed to b"..., 79) = 79

Which corresponds to:
brSetInterfaceUp() in libvirt

and 
dev_change_flags() in the kernel,

if ((old_flags ^ flags) & IFF_UP) {     /* Bit is different  ? */
                ret = ((old_flags & IFF_UP) ? dev_close : dev_open)(dev);

where it seems that dev_open() is failing.
Comment 1 Daniel Berrange 2007-11-20 16:08:06 EST

*** This bug has been marked as a duplicate of 390991 ***

Note You need to log in before you can comment on or make changes to this bug.