Bug 393061 - x server won't start
x server won't start
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-20 15:54 EST by Ray Todd Stevens
Modified: 2008-03-25 13:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-25 13:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
from failed attempt (28.45 KB, text/plain)
2007-11-21 14:14 EST, Ray Todd Stevens
no flags Details
X config from failed attempt (745 bytes, text/plain)
2007-11-21 14:17 EST, Ray Todd Stevens
no flags Details

  None (edit)
Description Ray Todd Stevens 2007-11-20 15:54:03 EST
Description of problem:

Now this worked with fc7 so this is a change problem with fc8   Anyway the
system will not start the x server when installing

Version-Release number of selected component (if applicable):

How reproducible:


additional information   intel e7221 controler embeded in supremicro mother board

Steps to Reproduce:
1. take the rescue cd and boot using the first option
2. wait
3. anaconda says it is running
4. properly identifies the controler
5. Says it is starting the x server.  (Doesn't it normally idenfiy the monitor 
too???   It doesn't in this case  
6. then returns with several attempts to start x
7  then returns with can't start x server and wants to know if you want to do
text or vnc??? ?

Actual results:

see above

Expected results:

ability to install

Additional info:
Comment 1 Chris Lumens 2007-11-20 19:45:06 EST
Please attach /tmp/ramfs/X.log and /tmp/XConfig.test to this bug report.
Comment 2 Ray Todd Stevens 2007-11-21 14:14:43 EST
Created attachment 266241 [details]
from failed attempt
Comment 3 Ray Todd Stevens 2007-11-21 14:17:12 EST
Created attachment 266251 [details]
X config from failed attempt
Comment 4 Ray Todd Stevens 2007-11-23 11:18:33 EST
Have had the same problem with a second similar server so it is probably not a
bad hardware issue.
Comment 5 Ray Todd Stevens 2007-11-26 15:31:20 EST
OK I have three machines with similar hardware configurations.   All three
experience this error.   Interestingly the upgrade worked fine otherwise, but in
the forced text mode.   Then the systems boot up (I always poer boot after a
upgrade) and the x server crashes, and again drops you to text mode.   But once
it does this once, then they start working again.

I have looked at all the logs with no indication of why this occurs.  But it did
occur on all three.

Anyway all three are upgraded, so I am happy.  But it occurs to me that down the
road in the near term someone needs to find out why this happened.  The good
news is that these are three identical machines for a purpose.   

One is a production server, which quite frankly it takes an act of God to get
permission to take down for even a few minutes.   But the other two are test
servers.   One is a test and standby server for the production server, and the
other is a long term advanced test machine for the production server.   The
point here is that these two machines I can in fact take down without normally
requiring outside permission, and so if something additional needs to be tested
let me know.   I can test it with no problems.
Comment 6 Ray Todd Stevens 2007-12-09 15:51:53 EST
Interesting additional clue.   On these same systems, during the boot up process
they used to switch to a xwindows monitoring of the boot process.   Now they
appear to error out when attempting this, and then goes on with the text based
boot monitor.   Then at the end of the boot process xwindows starts normally and
we are off to the races.
Comment 7 Ray Todd Stevens 2007-12-19 23:30:20 EST
I have actaully been seeing this last problem on a lot of machines.
Comment 8 Ray Todd Stevens 2008-01-02 16:52:18 EST
At this point all of my FC8 machines are doing comment 6.   I find this very

But otherwise they are working, and generally one should not need to reboot very
Comment 9 Adam Jackson 2008-02-11 17:34:29 EST
(EE) GARTInit: Unable to open /dev/agpgart (No such device)

Anaconda isn't setting up enough of a /dev for us.  Booooo.
Comment 10 Chris Lumens 2008-02-13 11:44:12 EST
Since we've recently removed all the code that has anything to do with setting
up /dev, we are most likely no longer failing to set up /dev/agpgart.  Is this
problem fixed in Rawhide (or F9 Alpha)?
Comment 11 Ray Todd Stevens 2008-02-14 17:37:12 EST
The problem is that both the Rawhide that I can tell and also FC9 Alpha don't
support the over the network install, which is the method I use.   Any ideas on
how I might test this?
Comment 12 Ray Todd Stevens 2008-03-06 13:03:09 EST
I have found out how to do a over the net install of fc9a1 and so far have found
that the same machines don't seem to have this problem.
Comment 13 Chris Lumens 2008-03-25 13:30:35 EDT
Closing on the basis of comment #12.  Feel free to reopen this bug if this
problem comes back up.

Note You need to log in before you can comment on or make changes to this bug.