This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 393511 - deluge crashes when starting, his start is imprevisible, sometimes yes, sometimes not
deluge crashes when starting, his start is imprevisible, sometimes yes, somet...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 20:15 EST by Ivan Quirino
Modified: 2007-12-06 18:53 EST (History)
0 users

See Also:
Fixed In Version: 0.5.6.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 17:31:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bug reporting tool gives me this file (501.53 KB, text/plain)
2007-11-20 20:17 EST, Ivan Quirino
no flags Details

  None (edit)
Description Ivan Quirino 2007-11-20 20:15:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc8 Firefox/2.0.0.9

Description of problem:
Deluge runned fine the first time I installed it. But one time it crashed when starting, the GUI even completed loading, then the error screen appeared. I tried to run it again various times, rebooted the computer, and reinstalled deluge. but it didn't worked. I restarted X and didn't worked. But there was a time it simply worked. So I reboot the computer and it doesn't worked anymore. Deluge behaves strangely.

Version-Release number of selected component (if applicable):
deluge-0.5.6-1

How reproducible:
Always


Steps to Reproduce:
1. Run deluge, first time it works, if you close and start it again, maybe it can run or not. Unstable.
2. Reinstall deluge, maybe it can work or not, it works randomly, never previsible.
3.Reboot, restart X, kill python processes, and maybe it can run or not

Actual Results:
The crash report appeared, and then the application cloes

Expected Results:
the program should have worked, but it crashes. works sometimes.

Additional info:
deluge-0.5.6-1.i386
Comment 1 Ivan Quirino 2007-11-20 20:17:58 EST
Created attachment 265621 [details]
bug reporting tool gives me this file
Comment 2 Peter Gordon 2007-11-21 14:29:25 EST
Thank you for the bug report, and especially the GDB trace attached.

Please try reproducing your bug with 0.5.6.2-1, which was pushed to stable
yesterday; that release was noted to have fixed several crasher bugs. Does it
fix your issue?

If not, please run deluge from a terminal and note any debugging/error output
(such as a Python backtrace, et al.)
Comment 3 Ivan Quirino 2007-11-21 15:09:41 EST
Fedora 8 doesn't have a package for 0.5.6.2-1...
Comment 4 Peter Gordon 2007-11-21 15:28:35 EST
(In reply to comment #3)
> Fedora 8 doesn't have a package for 0.5.6.2-1...
 
It was pushed to the stable repository (from testing) yesterday evening, pacific
time. It perhaps has not hit your local mirror yet, in which case it should be
available from the updates-testing repository, then, which you can install by
running "yum --enablerepo=updates-testing update blam" as root.

Please let me know if this new release fixes or reduces your issues. Thanks.
Comment 5 Peter Gordon 2007-12-06 12:57:34 EST
Ivan, does this issue continue to persist? Please let know...
Comment 6 Ivan Quirino 2007-12-06 13:07:26 EST
deluge is now running fine!

never crashed anymore with 0.5.6.2
Comment 7 Peter Gordon 2007-12-06 17:31:36 EST
Good to hear. =)

I'll close this big as fixed, then.
Comment 8 Ivan Quirino 2007-12-06 18:53:26 EST
you could keep at the latest version, deluge development is very active and each
version corrects lots of bugs

thanks

Note You need to log in before you can comment on or make changes to this bug.