Bug 393531 - Rhythmbox crashes when starting
Rhythmbox crashes when starting
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 21:41 EST by Pedro Matiello
Modified: 2007-12-20 15:15 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.11.3-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 15:15:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full GDB log for comment #3 (13.03 KB, text/plain)
2007-11-21 11:43 EST, Pedro Matiello
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 499208 None None None Never

  None (edit)
Description Pedro Matiello 2007-11-20 21:41:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8.1.9) Gecko/20071105 Epiphany/2.20 Firefox/2.0.0.9

Description of problem:
Rhythmbox crashes when starting.

[pedro@spacelab ~]$ rhythmbox
55da0c3a-d1dd-efba-7696d36c-7ee5d4a0 is dumped

Version-Release number of selected component (if applicable):
rhythmbox-0.11.3-3.fc8

How reproducible:
Always


Steps to Reproduce:
1. Start Rhythmbox.

Actual Results:
Rhythmbox crashed.

Expected Results:
Rhythmbox should have started.

Additional info:
Comment 1 Pedro Matiello 2007-11-20 22:12:18 EST
It seems to be related to plugins. If you enable last.fm or disable Magnatune,
rhythmbox will crash on restart.
Comment 2 Bastien Nocera 2007-11-21 05:34:23 EST
Please gather a backtrace, following the instructions at:
http://fedoraproject.org/wiki/StackTraces
Comment 3 Pedro Matiello 2007-11-21 11:40:59 EST
I followed the documentation you pointed and got these results. If you need
more, please inform me.

(...) # Many messages complaining about missing separate debug info file (but I
don't know what more *-debuginfo packages to install - I installed
rhythmbox-debuginfo and glib2-debuginfo)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209170144 (LWP 5526)]
0x0805f95d in main (argc=Cannot access memory at address 0x1
) at main.c:325
325

(gdb) thread apply all bt

Thread 2 (Thread -1209170144 (LWP 5526)):
#0  0x0805f95d in main (argc=Cannot access memory at address 0x1
) at main.c:325

Thread 1 (process 5526):
#0  0x0805f95d in main (argc=Cannot access memory at address 0x1
) at main.c:325
0x0805f95d      325                     pyg_begin_allow_threads;
Comment 4 Pedro Matiello 2007-11-21 11:43:19 EST
Created attachment 266121 [details]
Full GDB log for comment #3

Full GDB log for comment #3.

I don't know if this is relevant, but it's here anyway.
Comment 5 Bastien Nocera 2007-11-21 15:08:43 EST
I can reproduce, unfortunately. It's a pygtk/threads bug, which I thought was
already fixed, and just came back again.
Comment 6 Pedro Matiello 2007-11-21 15:39:06 EST
Alright. If you need more information or testing, just call me here.
Comment 7 Bastien Nocera 2007-11-26 08:27:56 EST
I think I've been very lucky in reproducing this.

I've posted a work-around at:
http://bugzilla.gnome.org/show_bug.cgi?id=499208

"
Thanks to Jonathan, found out this was because no Python plugins were loaded
(therefore rb_python_module_init_python() was never being called), making
pyg_begin_allow_threads() crash.

Enable a python plugin, such as the artdisplay one, to work-around the crash:
gconftool-2 --set --type bool /apps/rhythmbox/plugins/artdisplay/active true
"
Comment 8 Pedro Matiello 2007-11-26 09:05:25 EST
It seems to be working fine. :)
Comment 9 Benjamin Thery 2007-12-01 06:35:11 EST
Same problem here. I have indeed deactivated most of the plugins.

The workaround works fine :) 
I hope you'll find a proper fix for this one as I don't need all this plugins. 
Comment 10 Fedora Update System 2007-12-03 06:44:49 EST
rhythmbox-0.11.3-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rhythmbox'
Comment 11 Pedro Matiello 2007-12-05 07:28:21 EST
It seems to be fixed. Thanks.
Comment 12 François Kooman 2007-12-16 06:15:58 EST
The rhythmbox from updates-testing fixes the problem for me too.
Comment 13 Fedora Update System 2007-12-20 15:15:54 EST
rhythmbox-0.11.3-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.