Bug 393751 - Astromenace does not start. To launch the game you need to go in /usr/share
Astromenace does not start. To launch the game you need to go in /usr/share
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: astromenace (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 03:36 EST by Erik Streb del Toro
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version: 1.2-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 14:51:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Streb del Toro 2007-11-21 03:36:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.9) Gecko/20071105 Galeon/2.0.3 Firefox/2.0.0.9

Description of problem:
To launch the game you need to go in /usr/share, else you get:

  Can't find VFS file astromenace/gamedata.vfs
  gamedata.vfs file not found or corrupted.

and the game does not start.


Version-Release number of selected component (if applicable):
astromenace-1.2-3.fc8

How reproducible:
Always


Steps to Reproduce:
1.cd in any directory but not /usr/share
2.start the game by typing astromenace
3.you get the above mentioned error (file not found…)

Actual Results:
The game did not start. I just received the message
  Can't find VFS file astromenace/gamedata.vfs
  gamedata.vfs file not found or corrupted.


Expected Results:
The game should start in any directory.

Additional info:
Comment 1 Erik Streb del Toro 2007-11-21 03:43:48 EST
The ArchLinux-Team had the same bug and solved it. Maybe one could ask them, how
they fixed it.

See here: http://aur.archlinux.org/packages.php?do_Details=1&ID=5683
the Comment by: peoro on 20070803 [20:13:22]

I hope this helps.
Comment 2 Jon Ciesla 2007-11-24 21:49:13 EST
So essentially, you'd like the executable replaced with a script that calls the
renamed executable with the options passed to it by the .desktop file?  I could
I suppose, do that.  May I ask why launching this from the .desktop file is not
sufficient?  What if a user wants to call alternate command line options to what
I choose?  They can currently do so.  It currently calls astromenace-wrapper
--noAA --dir=/usr/share/astromenace --mode=12, which in turn calls a script that
executes a DRI check.
Comment 3 Erik Streb del Toro 2007-12-06 17:17:17 EST
Yes, exactly that. I’d like the executable replaced with a script that calls the
renamed executable with the options passed to it by the .desktop file OR any
other improvement so that it just works and I (and others) don’t have to search
the internet for this “bug”.

> May I ask why launching this from the .desktop file is not sufficient?
I don’t know anything of a .desktop-file. I’m using Windowmaker, maybe that is
the reason? I start all of my programs by just typing the program name in the
console (i. e. thunderbird, galeon, kile, gnuplot, and so on).

> What if a user wants to call alternate command line options to what
> I choose?
So you say your above mentioned solution is not usable for all users? Isn’t
there another possibility to start your program easily without using Gnome (or
what is the .desktop file for?)? I use a lot of programs and I’m able to pass
them some options, too. Without any problems. And it does not matter in which
directory I am when I start them.

If I just understood something wrong, please tell me. But I think it should be
possible to start this game without reading the manual, any faq or the internet
(bugzillas of any distros).


(In reply to comment #2)
> So essentially, you'd like the executable replaced with a script that calls the
> renamed executable with the options passed to it by the .desktop file?  I could
> I suppose, do that.  May I ask why launching this from the .desktop file is not
> sufficient?  What if a user wants to call alternate command line options to what
> I choose?  They can currently do so.  It currently calls astromenace-wrapper
> --noAA --dir=/usr/share/astromenace --mode=12, which in turn calls a script that
> executes a DRI check.
> 

Comment 4 Jon Ciesla 2007-12-06 17:35:44 EST
The fedora-astromenace.desktop file is read by at least Gnome, KDE and XFCE, and
used to generate a menu item.  I'm not sure why the game is so picky about where
it's data is located.  I will attempt a patch to allow it to run without a --dir
flag.

I've just been given a patch to allow it to run without a --mode flag, so this
would be a good time to examine this.  Also, I understand there's a new upstream
version, so that might be fixed.  I'll check it out.
Comment 5 Jon Ciesla 2007-12-11 09:37:17 EST
I've got a patch which may correct this, I just need to test it, and I'll let
you know.
Comment 6 Jon Ciesla 2007-12-12 08:06:47 EST
Please try this build in koji/rawhide:
http://koji.fedoraproject.org/koji/buildinfo?buildID=27861
Comment 7 Fedora Update System 2007-12-20 14:50:57 EST
astromenace-1.2-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2007-12-20 14:54:05 EST
astromenace-1.2-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.