Bug 393761 - [RHEL5.2] evolution-exchange-storage has a memory leak
[RHEL5.2] evolution-exchange-storage has a memory leak
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution-connector (Show other bugs)
5.1
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Milan Crha
desktop-bugs@redhat.com
:
Depends On:
Blocks: 460669
  Show dependency treegraph
 
Reported: 2007-11-21 03:42 EST by Peter Wainwright
Modified: 2009-09-02 05:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:16:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 523023 None None None Never

  None (edit)
Description Peter Wainwright 2007-11-21 03:42:44 EST
Description of problem:

evolution-exchange-storage seemingly has a memory leak.


Version-Release number of selected component (if applicable):

evolution-connector-2.8.0-3.fc6

How reproducible:


Steps to Reproduce:
1. Start evolution.
2. Subscribe to Microsoft Exchange account using Outlook Web Access.
   My receive options include check for new mail every 10 minutes,
   automatically synchronize account locally,
   apply filters to new messages in Inbox on this server.
3. Wait a few hours...
  
Actual results:

Between 15:30 yesterday and 8:00 today the virtual memory size of the
evolution-exchange-storage process increased from 680M (big enough, to be frank)
to 1225M.  On other occasions, I have left it longer and there is no limit to
the amount it will gobble.


Expected results:

No increasing trend in memory use.

Additional info:

It appears that something is being allocated and not freed every time this
process contacts the Exchange server.  This probably depends on what is on the
server, if you need more information or have particular diagnostic tests you can
suggest please contact me.  The problem has existed since I first tried using
Evolution connector sometime back in RHEL 4.

The problem does not seem to occur with version 2.12.0-0ubuntu1 on my Ubuntu
box, but I cannot upgrade the evolution version on my RHEL box because
gnome-panel needs specific library versions (dependency hell!)
Comment 1 Matthew Barnes 2007-11-21 10:14:14 EST
Evolution will be rebased to version 2.12 in the next RHEL5 update, so it sounds
like this problem is already taken care of.
Comment 2 Matthew Barnes 2008-03-24 10:49:56 EDT
Actually no, I found a rather severe memory leak in evolution-exchange-storage
that occurs everytime Evolution scans the Exchange folder tree.

See: http://bugzilla.gnome.org/show_bug.cgi?id=523023
Comment 5 RHEL Product and Program Management 2008-06-17 14:19:37 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 15 errata-xmlrpc 2009-09-02 05:16:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1261.html

Note You need to log in before you can comment on or make changes to this bug.