Bug 3938 - second stage loader fails to execute
second stage loader fails to execute
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-07 16:59 EDT by michal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-08 15:32:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michal 1999-07-07 16:59:31 EDT
In Red Hat distribution 6.0 for i386 with all current
updates (CD
created from 6.0 binaries posted on ftp sites and confirmed
that
various mirrors have the same contents in RedHat/base/ and
images/) an
attempt to boot fails silently at the start of the second
stage
loader.

Last messages on screen 3 look like follows:
....
* method selection completed
* state saved to /tmp
* error in exec of second stage loader :-(
*       error:Permission denied

Unfortunately after this the machine is practically dead
which
prevents an examination of a ramdisk.

This error occured on two different machines and persisted
even after
replacing an updated boot.img with the one from the original
distribution.  This error can be worked around by forcing,
from an
expert mode, a loading of supp.img; after that one can
proceed even if
modules.img was not loaded (because of a deliberate error).

A common factor may be that both machines on which this was
tried
have SCSI CD drive.

  Michal Jaegermann
  michal@harddata.com
Comment 1 David Lawrence 1999-07-08 15:32:59 EDT
are you downloading these files preserving all permissions as they
appear on our ftp site? it sounds like the install2 binary is not
marked as executable on your install media. If it is incorrect it can
be assumed that alot of other necessary binaries may be incorrectly
set. Reopen this bug if this is of no help.

Note You need to log in before you can comment on or make changes to this bug.