Bug 393831 - Kernel panic on setup_APIC_timer
Kernel panic on setup_APIC_timer
Status: CLOSED DUPLICATE of bug 251869
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 04:28 EST by CAI Qian
Modified: 2008-05-20 06:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 03:55:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2007-11-21 04:28:53 EST
Description of problem:
Kernel panic happened once.

Version-Release number of selected component (if applicable):
RHEL5.1 stock kernel

How reproducible:
not always
  
Actual results:
 Booting 'Red Hat Enterprise Linux Server (2.6.18-53.el5)'

root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.18-53.el5 ro root=/dev/VolGroup00/LogVol00 console=ttyS0,11
5200 crashkernel=128M@16M
   [Linux-bzImage, setup=0x1e00, size=0x1c033c]
initrd /initrd-2.6.18-53.el5.img
   [Linux-initrd @ 0x37cf2000, 0x2fd914 bytes]

Linux version 2.6.18-53.el5 (brewbuilder@hs20-bc1-7.build.redhat.com) (gcc
version 4.1.2 20070626 (Red Hat 4.1.2-14)) #1 SMP Wed Oct 10 16:34:19 EDT 2007
Command line: ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200
crashkernel=128M@16M
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000003fe8cc00 (usable)
 BIOS-e820: 000000003fe8cc00 - 000000003fe8ec00 (ACPI NVS)
 BIOS-e820: 000000003fe8ec00 - 000000003fe90c00 (ACPI data)
 BIOS-e820: 000000003fe90c00 - 0000000040000000 (reserved)
 BIOS-e820: 00000000f0000000 - 00000000f4000000 (reserved)
 BIOS-e820: 00000000fec00000 - 00000000fed00400 (reserved)
 BIOS-e820: 00000000fed20000 - 00000000feda0000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fef00000 (reserved)
 BIOS-e820: 00000000ffb00000 - 0000000100000000 (reserved)
DMI 2.3 present.
No NUMA configuration found
Faking a node at 0000000000000000-000000003fe8c000
Bootmem setup node 0 0000000000000000-000000003fe8c000
ACPI: PM-Timer IO Port: 0x808
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
Processor #0 15:4 APIC version 20
ACPI: LAPIC (acpi_id[0x02] lapic_id[0x01] enabled)
Processor #1 15:4 APIC version 20
ACPI: LAPIC (acpi_id[0x03] lapic_id[0x05] disabled)
ACPI: LAPIC (acpi_id[0x04] lapic_id[0x07] disabled)
ACPI: LAPIC_NMI (acpi_id[0xff] high level lint[0x1])
ACPI: IOAPIC (id[0x08] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 8, version 32, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
Setting APIC routing to physical flat
ACPI: HPET id: 0x8086a201 base: 0xfed00000
Using ACPI (MADT) for SMP configuration information
Nosave address range: 00000000000a0000 - 00000000000f0000
Nosave address range: 00000000000f0000 - 0000000000100000
Allocating PCI resources starting at 50000000 (gap: 40000000:b0000000)
SMP: Allowing 4 CPUs, 2 hotplug CPUs
Built 1 zonelists.  Total pages: 256866
Kernel command line: ro root=/dev/VolGroup00/LogVol00 console=ttyS0,115200
crashkernel=128M@16M
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 32768 bytes)
Console: colour VGA+ 80x25
Dentry cache hash table entries: 131072 (order: 8, 1048576 bytes)
Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
Checking aperture...
Memory: 891300k/1047088k available (2434k kernel code, 155404k reserved, 1235k
data, 192k init)
Calibrating delay using timer specific routine.. 5590.87 BogoMIPS (lpj=2795437)
Security Framework v1.0.0 initialized
SELinux:  Initializing.
selinux_register_security:  Registering secondary module capability
Capability LSM initialized as secondary
Mount-cache hash table entries: 256
CPU: Trace cache: 12K uops, L1 D cache: 16K
CPU: L2 cache: 1024K
using mwait in idle threads.
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 0
CPU0: Thermal monitoring enabled (TM1)
SMP alternatives: switching to UP code
ACPI: Core revision 20060707
Using local APIC timer interrupts.
result 12469490
Detected 12.469 MHz APIC timer.
NMI Watchdog detected LOCKUP on CPU 0
CPU 0 
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.18-53.el5 #1
RIP: 0010:[<ffffffff8007478b>]  [<ffffffff8007478b>] setup_APIC_timer+0x25/0xba
RSP: 0000:ffff81000974de90  EFLAGS: 00000002
RAX: 000000001a1c535f RBX: 0000000000000082 RCX: ffffffff80441520
RDX: 0000000000716382 RSI: 0000000000000000 RDI: 0000000000030b57
RBP: 00000000000003e8 R08: 0000000000000000 R09: 000000000000003e
R10: ffffffff803c3500 R11: 0000000000000000 R12: 0000000000000000
R13: 0000000000000000 R14: 0000000000000000 R15: 0000000000000000
FS:  0000000000000000(0000) GS:ffffffff80396000(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 0000000000000000 CR3: 0000000000201000 CR4: 00000000000006e0
Process swapper (pid: 1, threadinfo ffff81000974c000, task ffff8100097417a0)
Stack:  000000000be44f20 ffffffff803db787 0000000000090000 000030b500020800
 0000000000090000 0000000000020800 0000000000090000 ffffffff803d18c4
 0000000000000000 0000000000000000 0000000000000000 0000000000000000
Call Trace:
 [<ffffffff803db787>] setup_boot_APIC_clock+0x115/0x11d
 [<ffffffff803d18c4>] init+0x62/0x2f9
 [<ffffffff8005bfb1>] child_rip+0xa/0x11
 [<ffffffff80168854>] acpi_ds_init_one_object+0x0/0x80
 [<ffffffff803d1862>] init+0x0/0x2f9
 [<ffffffff8005bfa7>] child_rip+0x0/0x11


Code: 39 d0 73 f5 8b 04 25 f0 e0 5f ff 39 d0 73 43 eb f3 31 c0 e6 
Kernel panic - not syncing: nmi watchdog
 BUG: warning at kernel/panic.c:137/panic() (Not tainted)

Call Trace:
 <NMI>  [<ffffffff8008ccca>] panic+0x1e3/0x1f4
 [<ffffffff8006948b>] _show_stack+0xdb/0xea
 [<ffffffff8006957e>] show_registers+0xe4/0x100
 [<ffffffff8006347b>] die_nmi+0x66/0xa3
 [<ffffffff80063aff>] nmi_watchdog_tick+0x107/0x1fb
 [<ffffffff800637e4>] default_do_nmi+0x86/0x214
 [<ffffffff80063c36>] do_nmi+0x43/0x61
 [<ffffffff8006309f>] nmi+0x7f/0x88
 [<ffffffff8007478b>] setup_APIC_timer+0x25/0xba
 <<EOE>>  [<ffffffff803db787>] setup_boot_APIC_clock+0x115/0x11d
 [<ffffffff803d18c4>] init+0x62/0x2f9
 [<ffffffff8005bfb1>] child_rip+0xa/0x11
 [<ffffffff80168854>] acpi_ds_init_one_object+0x0/0x80
 [<ffffffff803d1862>] init+0x0/0x2f9
 [<ffffffff8005bfa7>] child_rip+0x0/0x11


Additional info:
Unfortunately, I don't have crash dump of it.
Comment 1 CAI Qian 2007-11-21 04:31:38 EST
The affected machine is
dell-pesc430-02.rhts.boston.redhat.com
Comment 2 Prarit Bhargava 2007-11-26 13:33:25 EST
Cai, we had seen this occur on a couple of systems in RH.  Could you try a newer
kernel?

This is likely a duplicate of 251869.

P.
Comment 3 CAI Qian 2007-11-27 03:55:48 EST

*** This bug has been marked as a duplicate of 251869 ***
Comment 4 Cheng Ho Lin 2008-05-20 02:28:37 EDT
On our platform of RHEL5.0 x86_64 (Linux kernel 2.6.18-8.el5),
the bug of "kernel panic - not syncing : nmi watchdog" occurs from time to 
time.

As I investigate this problem, my bugzilla account have no permission to look 
into bug #251869. By googling, it seems that Linux kernel 2.6.24.x still 
encounter "kernel panic - not syncing : nmi watchdog" . Which version of 
kernel or can solve this issue ? Does RHEL 5.2 fix this bug ?

ps. The call trace on our platform was listed as follows:

Code: 39 d0 73 f5 8b 04 25 f0 e0 5f ff 39 d0 73 43 eb f3 31 c0 e6 
Kernel panic - not syncing: nmi watchdog
 BUG: warning at kernel/panic.c:137/panic() (Not tainted)

Call Trace:
 <NMI>  [<ffffffff8008b476>] panic+0x1e3/0x1f4
 [<ffffffff80069261>] _show_stack+0xdb/0xea
 [<ffffffff80069354>] show_registers+0xe4/0x100
 [<ffffffff8006300b>] die_nmi+0x66/0xa3
 [<ffffffff8006368d>] nmi_watchdog_tick+0x107/0x1fb
 [<ffffffff80063374>] default_do_nmi+0x86/0x214
 [<ffffffff80063771>] do_nmi+0x43/0x61
 [<ffffffff80062c2f>] nmi+0x7f/0x88
 [<ffffffff80073e3f>] setup_APIC_timer+0x25/0xba
 <<EOE>>  [<ffffffff803cf3d9>] setup_boot_APIC_clock+0x115/0x11d
 [<ffffffff80067e5e>] init+0x62/0x3c5
 [<ffffffff8005bfe5>] child_rip+0xa/0x11
 [<ffffffff80160e95>] acpi_ds_init_one_object+0x0/0x80
 [<ffffffff80067dfc>] init+0x0/0x3c5
 [<ffffffff8005bfdb>] child_rip+0x0/0x11
Comment 5 Prarit Bhargava 2008-05-20 06:16:49 EDT
(In reply to comment #4)
> On our platform of RHEL5.0 x86_64 (Linux kernel 2.6.18-8.el5),
> the bug of "kernel panic - not syncing : nmi watchdog" occurs from time to 
> time.
> 
> As I investigate this problem, my bugzilla account have no permission to look 
> into bug #251869. By googling, it seems that Linux kernel 2.6.24.x still 
> encounter "kernel panic - not syncing : nmi watchdog" . Which version of 
> kernel or can solve this issue ? Does RHEL 5.2 fix this bug ?
> 

RHEL 5.2 should contain a fix for this issue.

P.

Note You need to log in before you can comment on or make changes to this bug.