Bug 39385 - Disk space warning / More swap space / ReiserFS
Disk space warning / More swap space / ReiserFS
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-07 10:28 EDT by Stefan Furtmayr
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-17 18:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Furtmayr 2001-05-07 10:28:32 EDT
Description of problem:

- warn if installing everything (2.3 GB) on a 2.5 GB partition - currently 
it takes quite some time before the installation aborts
- recommend larger swap partition for kernel 2.4 not only on upgrade but 
even in expert mode (i used 128 MB swap with 128 MB RAM and later chose to 
do a fresh install)
- not possible to create reiserfs partition in disk druid (expert mode)
Comment 1 Brent Fox 2001-05-07 14:32:07 EDT
Problem #1:  What was the state of the system when the install aborts?  What
happens exactly?

Problem #2:  I wouldn't call this a bug, but maybe you're right.  Perhaps expert
install should give you the choice, but on the other hand, you *really* want 2x
ram for swap with the 2.4 kernel.  That's what Linus recommends, but hey, maybe
'expert' install should let you do what you want anyway.

Problem #3:  We do not currently support ReiserFS.  Reiser is something that we
are evaluating.  Nothing against it...maybe it's totally fine for most uses, but
we can't recommend something for enterprise level systems that we haven't tested
for that level of use.
Comment 2 Stefan Furtmayr 2001-05-08 12:43:20 EDT
Problem #1:
>What was the state of the system when the install aborts?
what exactly do you need to know?

>What happens exactly?
the installer tells me that i needs over 300 MB more diskspace, should be easy 
to reproduce


Problem #2:
>install should give you the choice, but on the other hand, you *really* want 2x
>ram for swap with the 2.4 kernel.  That's what Linus recommends, but hey, maybe
>'expert' install should let you do what you want anyway.

it should warn, but not force - maybe it was text mode, not expert mode


Problem #3:
>but we can't recommend something for enterprise level systems that
>we haven't tested for that level of use.
ReiserFS was included in some other distributions - already before Kernel 2.4 - 
so why not?

Another useful thing would be to include the Windows version of RawWrite 
(http://uranus.it.swin.edu.au/~jn/linux/)
Comment 3 Brent Fox 2001-05-08 15:23:05 EDT
Problem #1:  Did the install crash or did it hang?  Were they any dialog messages?

Problem #2:  Agreed.  Warn but not force is almost always the way to go.

Problem #3:  Yes, other distros ship ReiserFS.  Just because they do doesn't
mean that it is ready for prime time.  Some other distros also shipped kernel
2.4.0, which didn't pass the VA Cerberus
(http://sourceforge.net/projects/va-ctcs/) kernel stress test.  If you are
really in need of a journaling filesystem, I'd recommend the XFS modification to
Red Hat Linux 7.1 that SGI put together.  It modifies our installer to let you
create XFS filesystems during installation.  I've played around with it and it's
pretty neat.  

There's always a tradeoff between things that are really cool, cutting edge kind
of stuff, although they might not be complete at the moment (Mozilla comes to
mind) and things that are crucial.  However, I think something as crucial as the
filesystem is not the place for that.
Comment 4 Stefan Furtmayr 2001-05-09 13:35:45 EDT
Problem #1:

i could reproduce it on a second system with a celeron and 64 MB ram:

1. transferring install image...
2. package installation (without any progress)
3. preparing to install...
4. disk space: 141MB more needed
5. going back to "x probe results"

2. + 3. took 3 minutes! - too much to for recognizing that a 2324 MB selection 
does not fit on 2500 MB

Problem #3:

ok, but are there also any reasons not to include rawwrite for windoze and 
parted (i think it is much more useful than fips)
Comment 5 Brent Fox 2001-05-14 22:18:40 EDT
I'm trying to understand exactly what is happening.  Does the installer hang or
does it crash?  If it crashes, what are the error messages?
Comment 6 Stefan Furtmayr 2001-05-15 14:08:20 EDT
>I'm trying to understand exactly what is happening.  Does the installer hang or
>does it crash?  If it crashes, what are the error messages?

as i described on 2001-05-09 the installer did not crash but only showed no 
progress during a long time. It should be easy to check the diskspace and 
reccomend a larger partition size at an ealier stage of the installation.
Comment 7 Brent Fox 2001-05-17 18:12:38 EDT
It's actually much harder than you might think.  The problem is that the package
selection screen really ought to come before partitioning.  That way, we could
know exactly how much the user wants to install, so we could force the
partitions to meet the minimal requirements based on the packages selected.  The
problem is that reading the RPM headers takes quite a bit of memory.  For
machines with a small amount of RAM, we have to turn on swap before the package
selection screen so they'll have enough space to even get to the screen. 
Turning on swap requires that we do at least some basic partitioning.  I agree
totally with you, but I've been told by the other developers that it would be
tough to fix for a pretty minimal gain.  
Most users these days have pretty big hard drives, so this problem doesn't come
up that often.

Note You need to log in before you can comment on or make changes to this bug.