Bug 394031 - Ambiguous text in tune2fs man page
Ambiguous text in tune2fs man page
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Oliver Falk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 07:10 EST by Fred New
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 07:37:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred New 2007-11-21 07:10:13 EST
Description of problem:

Near the top of the man page, we see the following text:

"-c max-mount-counts
       Adjust the number of mounts after which the filesystem  will  be
       checked  by e2fsck(8).  If max-mount-counts is 0 or -1, the num-
       ber of times the filesystem is mounted will  be  disregarded  by
       e2fsck(8) and the kernel."

If my max-mount-counts is 0 or -1, will the system check my filesystem at the
next boot, or not?  Is there a default action defined for when e2fsck and the
kernel disregard the number of filesystem mounts?


Version-Release number of selected component (if applicable):
e2fsprogs-1.40.2-10.fc8  (But I see similar text on RHEL systems.)
Comment 1 Oliver Falk 2007-11-21 07:37:28 EST
(In reply to comment #0)
> Description of problem:
> 
> Near the top of the man page, we see the following text:
> 
> "-c max-mount-counts
>        Adjust the number of mounts after which the filesystem  will  be
>        checked  by e2fsck(8).  If max-mount-counts is 0 or -1, the num-
>        ber of times the filesystem is mounted will  be  disregarded  by
>        e2fsck(8) and the kernel."
> 
> If my max-mount-counts is 0 or -1, will the system check my filesystem at the
> next boot, or not?  Is there a default action defined for when e2fsck and the
> kernel disregard the number of filesystem mounts?

Well, you should have better asked that on the m/l instead of opening bz. However.

I've never used -1, but for 0 I know, the mount-count is ignored and the system
will never do a fsck - if the system is shut down cleanly. If the system
crashes, that's a total other story...

However. If you want to force a filesystem check at some reboot, you usually
should touch /forcefsck. I never used that but I guess it will work... :-)
Comment 2 Fred New 2007-11-21 07:56:41 EST
The idea here was to get the text fixed, not to just get the answer to my
questions.  Although, filing this bug in the upstream bugzilla might have been
more useful.
Comment 3 Oliver Falk 2007-11-21 08:12:57 EST
Of course. If you want such a change, you better file a bug upstream. Although I
think the man-page is quite clear...
Comment 4 Fred New 2007-11-21 08:48:47 EST
Yes, I see what the man page means now.  For me it is unclear because when I use
"dumpe2fs -h /dev/...", I see

<snip>
Mount count:              10
Maximum mount count:      -1
<snip>

To me, the tune2fs man page says that it will disregard the 10 (mount count) and
substitute something like -99999 or 99999.  But what it really means is that
"the mount count test won't be used to determine whether e2fsck will be run."
Comment 5 Oliver Falk 2007-11-21 11:09:02 EST
Yes. That does it mean. :-)

Note You need to log in before you can comment on or make changes to this bug.