Bug 39404 - firewall blocks nfs and nis
firewall blocks nfs and nis
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-07 11:19 EDT by Sasha
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-07 11:19:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sasha 2001-05-07 11:19:41 EDT
Description of problem:
Choices of "medium" or "high" level in firewall configuration make it
impossible to get usernames/passwords from NIS server, or to mount a file
system via NFS (I am tlaking about installation on a clicent machine, not
server). Since both of these operations are pretty standard ofr a
worksatation in a networked environment, it would be helpful if firewall
configuration tool had an option to allow for such operations. Or, if this
is impossible, it should be clearly stated in online help that if you need
to use any of these functions, you should choose "no firewall" setting. 

How reproducible:
Always

Steps to Reproduce:
During the installation, select  "medium" level for firewall configuration.
After the installation is complete, try mounting an NFS file system using
"mount" command. It fails. Now use lokkit to disable firewall and try again
- this time, it will work.  	

Additional info:
Comment 1 Bill Nottingham 2001-05-07 17:29:46 EDT
Please see the release notes; this is very clearly documented there.
Comment 2 Sasha 2001-05-07 18:00:35 EDT
Sorry, but...what are release notes? I went to RH7.1 web page
http://www.redhat.com/products/software/linux/7-1_standard.html
and there is nothing like release notes there. There is a README file on the CD,
but again, nothing like release notes there. 

I looked at the installation guide
(http://www.redhat.com/support/manuals/RHL-7.1-Manual/install-guide/)
and it says nothing about NFS or NIS. Yes, it does mention that the firewall
blocks all ports below 1024 - which suffices for experts but not for the
majority of users, and it mentions NFS *server* port - but I am talking about
client side.

Anyway: I am not saying this is a bug - I marked it as "enhancement request" -
but I do think it would help many users if such an option were added - or if
not, then the warning about blocking NIS and NFS should be put in big red
letters right there next to the checkboxes. It'd definitely have helped me. 

Note You need to log in before you can comment on or make changes to this bug.