Bug 394191 - makeinfo looks broken while generating START-INFO-DIR-ENTRY
makeinfo looks broken while generating START-INFO-DIR-ENTRY
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 09:34 EST by Dmitry Antipov
Modified: 2007-12-21 16:11 EST (History)
0 users

See Also:
Fixed In Version: 4.11-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 16:11:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Antipov 2007-11-21 09:34:05 EST
On F8, makeinfo is probably broken since it generates wrong START-INFO-DIR-ENTRY
entries.

Consider the following Texinfo input test.texi:

\input texinfo
@setfilename test
@settitle Foo manual

@dircategory Misc
@direntry
* Foo: (foo).           Mega-Foo.
@end direntry

With makeinfo from texinfo-4.11, result of 'makeinfo --force test.texi' is:

INFO-DIR-SECTION Misc
START-INFO-DIR-ENTRY
This is test, produced by makeinfo version 4.11 from test.texi.

* Foo: (foo).           Mega-Foo.
END-INFO-DIR-ENTRY

But, with makeinfo from texinfo 4.8, the result was:

This is test, produced by makeinfo version 4.8 from test.texi.

INFO-DIR-SECTION Misc
START-INFO-DIR-ENTRY
* Foo: (foo).           Mega-Foo.
END-INFO-DIR-ENTRY

I.e. the description "This is ..." is not within
START-INFO-DIR-ENTRY/END-INFO-DIR-ENTRY block.
Comment 1 Vitezslav Crhonek 2007-12-10 11:18:15 EST
Thanks for reporting, fixed texinfo-4.11-3.fc8 will be pushed to testing soon.
Comment 2 Fedora Update System 2007-12-10 15:44:58 EST
texinfo-4.11-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update texinfo'
Comment 3 Fedora Update System 2007-12-21 16:11:06 EST
texinfo-4.11-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.