Bug 394481 - configuration file details page a mess in internet explorer
configuration file details page a mess in internet explorer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Máirín Duffy
wes hayutin
:
: 398131 (view as bug list)
Depends On:
Blocks: 248643 317791
  Show dependency treegraph
 
Reported: 2007-11-21 11:29 EST by Máirín Duffy
Modified: 2010-10-22 16:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 17:06:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhn-basic.css (9.12 KB, text/css)
2007-11-23 22:49 EST, Máirín Duffy
no flags Details
Here is what screens affected by this bug look like. (30.51 KB, image/gif)
2007-11-23 22:50 EST, Máirín Duffy
no flags Details
ss (162.08 KB, image/png)
2007-12-18 12:02 EST, wes hayutin
no flags Details
ss 2 (161.69 KB, image/png)
2007-12-18 12:02 EST, wes hayutin
no flags Details

  None (edit)
Description Máirín Duffy 2007-11-21 11:29:46 EST
Description of problem:

we have an embedded stylesheet in /rhn/configuration/file/FileDetails.do - it
has a bug that is causing this page to be extremely difficult to read in
internet explorer (reporter used IE 6 sp 2)

I would like to remove the embedded stylesheet and correct the CSS properly via
the centralized stylesheets.

This should not be a blocker but it is simple to test and should be easy to fix.
Comment 1 Máirín Duffy 2007-11-21 12:30:37 EST
revs  134139 + 134143 + 134144 should address this, putting ON_DEV

TEST PLAN
=========

Visit the following pages in firefox, IE 6, and IE 7 and make sure that the left
and right details areas ofthe page are in side-by-side columns... note that the
context menu is still a little crufty, but the page should be generally readable
in IE. 

1) /rhn/configuration/file/FileDetails.do (file details and file properties
columns should be side by side rather than bleeding into each other or on top of
each other)

2) /rhn/configuration/ChannelOverview.do (channel properties and configuration
actions columns should be side by side)
Comment 2 Máirín Duffy 2007-11-23 22:48:39 EST
for customers experiencing this issue, you may test the fix by backing up your
/var/www/html/css/rhn-basic.css file and replacing it with the attached file to
follow.
Comment 3 Máirín Duffy 2007-11-23 22:49:11 EST
Created attachment 267911 [details]
rhn-basic.css
Comment 4 Máirín Duffy 2007-11-23 22:50:32 EST
Created attachment 267921 [details]
Here is what screens affected by this bug look like.
Comment 5 Máirín Duffy 2007-11-24 22:45:44 EST
*** Bug 398131 has been marked as a duplicate of this bug. ***
Comment 6 John Ha 2007-12-12 22:03:35 EST
Here is a release note for this issue as suggested by Mairin:

 A cascading stylesheet bug when displaying the Configuration File Details page in
 Internet Explorer 6 has been fixed.

Comment 7 wes hayutin 2007-12-18 12:02:08 EST
looks much better however... if you look carefully the 
on ChannelOverview, the "Overview" List/Remove  Add Files Systems" menu items
should be above the grey line

on FileDetails  "details, manage revisions etc.. should also be above the grey line
Comment 8 wes hayutin 2007-12-18 12:02:36 EST
Created attachment 289901 [details]
ss
Comment 9 wes hayutin 2007-12-18 12:02:59 EST
Created attachment 289902 [details]
ss 2
Comment 10 wes hayutin 2007-12-18 12:03:45 EST
notice in the above screenshots the menu's look a little weird.  the menu items
should be above the grey line.
thanks
Comment 11 Máirín Duffy 2007-12-18 12:05:15 EST
"note that the
context menu is still a little crufty, but the page should be generally readable
in IE. " from comment 1.... that IS the cruftiness mentioned. There isn't any
way to fix that without causing other problems, like the left and right columns
to overlap as they were before. The page is readable now which it wasn't before.

please reconsider? :) ? :) ?
Comment 12 wes hayutin 2007-12-18 12:22:17 EST
yup.. and I looked at a 5.01 sat.. and the menu items are the same... so this is
fine..
sorry for the scare :)

verified build 32
Comment 13 Brandon Perkins 2008-04-02 17:06:48 EDT
UI Enhancements for 5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.