Bug 394581 - Enforce report_lost_ticks boot time parameter in time.c
Enforce report_lost_ticks boot time parameter in time.c
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Prarit Bhargava
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 11:47 EST by John Sobecki
Modified: 2008-05-21 11:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:02:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
enforce report_lost_ticks (793 bytes, text/x-patch)
2007-11-21 11:47 EST, John Sobecki
no flags Details
RHEL5 fix for this issue (1.18 KB, patch)
2007-11-27 13:48 EST, Prarit Bhargava
no flags Details | Diff

  None (edit)
Description John Sobecki 2007-11-21 11:47:49 EST
Description of problem:

During high database load testing (Oracle OLT) the kernel issues both of
these lost tick related warning messages:

1) kernel: warning: many lost ticks.
   kernel: Your time source seems to be instable or some driver is 
           hogging interupts

2)  kernel: Losing some ticks... checking if CPU frequency changed.

Version-Release number of selected component (if applicable):

2.6.18.*

How reproducible:

Under large Oracle OLT load testing, with 1000+ processes, this can
be reproduced 100% of the time. 

Steps to Reproduce:
1. Create Oracle DB
2. Load OLT test kit (available at htto://oss.oracle.com/projects/olt)
3. Run large load with 1000+ processes
  
Actual results:

Machine will slow and kick out multiple lost ticks messages.
Expected results:

Only print lost ticks messages if booted with 'report_lost_ticks'.

Additional info:

Customer noticed this after they switched from SLES9 to RHEL5; in SLES9
there is only one place where lost ticks warnings are printed, and it
includes an if (report_lost_ticks) check before the code block.
Comment 1 John Sobecki 2007-11-21 11:47:49 EST
Created attachment 266131 [details]
enforce report_lost_ticks
Comment 4 Prarit Bhargava 2007-11-27 13:48:50 EST
Created attachment 270051 [details]
RHEL5 fix for this issue

Updated patch.
Comment 5 RHEL Product and Program Management 2007-12-05 19:15:33 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Don Zickus 2007-12-17 14:37:42 EST
in 2.6.18-61.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 10 errata-xmlrpc 2008-05-21 11:02:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.