Bug 394691 - unable to access ide tape drive
Summary: unable to access ide tape drive
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-21 18:14 UTC by Craig Goodyear
Modified: 2007-12-20 19:56 UTC (History)
1 user (show)

Fixed In Version: 2.6.23.9-85.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-20 19:56:24 UTC


Attachments (Terms of Use)
the output from smolt (5.47 KB, text/plain)
2007-11-21 18:16 UTC, Craig Goodyear
no flags Details
output from dmesg (29.11 KB, text/plain)
2007-11-21 18:17 UTC, Craig Goodyear
no flags Details

Description Craig Goodyear 2007-11-21 18:14:21 UTC
Description of problem:
Any attempt to use the ide tape drive rewults in the 
error: Input/output error


Version-Release number of selected component (if applicable):
Kernel: 2.6.23.1-49.fc8
mt-st: 0.9b-4.fc8
tar: 1.17-4-fc8

How reproducible:
every time

Steps to Reproduce:
1. use mt -f /dev/nst0 tell
or 
2. use tar -cf /dev/nst0 /home

  
Actual results:
1. [root@cm2 dev]# mt -f /dev/nst0 tell
/dev/nst0: Input/output error

2. [root@cm2 craig]# tar -cf /dev/nst0 /home
tar: /dev/nst0: Cannot open: Input/output error
tar: Error is not recoverable: exiting now

Expected results:
execution of command without error

Additional info:
The output from smolt and dmesg are attached

Comment 1 Craig Goodyear 2007-11-21 18:16:28 UTC
Created attachment 266201 [details]
the output from smolt

This is the output from smolt.

Comment 2 Craig Goodyear 2007-11-21 18:17:50 UTC
Created attachment 266211 [details]
output from dmesg

This is the output from dmesg.

Comment 3 Chuck Ebbert 2007-11-21 20:11:08 UTC
Looks like this is needed:
f8d8e5799b75cf7ad530d2bf2a42229bf7360526
libata: increase 128 KB / cmd limit for ATAPI tape drives

Plus these not-upstream ones:
[PATCH 1/2] libata: workaround DRQ=1 ERR=1 for ATAPI tape drives
[PATCH 2/2] libata: use ATA_HORKAGE_STUCK_ERR for ATAPI tape drives

And maybe more?


Comment 4 Alan Cox 2007-11-21 22:01:12 UTC
DRQ/Stuck err should be sufficient. The other is a performance item but should
go in too


Comment 5 Chuck Ebbert 2007-12-05 20:40:54 UTC
Fixes are in F8 kernels starting with 2.6.23.9-79

Comment 6 Fedora Update System 2007-12-12 20:00:14 UTC
kernel-2.6.23.9-85.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'

Comment 7 Craig Goodyear 2007-12-13 16:11:17 UTC
I have installed kernel 2.6.23.9-85.fc8.  The ide tape drive 
now appears to fucntion correctly.  I am able to use the mt
commands to query and position the drive.  Tar now works to 
read from the drive and write to the drive.


Comment 8 Alan Cox 2007-12-13 18:39:09 UTC
Yay, thanks for testing


Comment 9 Fedora Update System 2007-12-20 19:56:15 UTC
kernel-2.6.23.9-85.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.