Bug 3949 - lockdsvc: Invalid argument
lockdsvc: Invalid argument
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-08 15:53 EDT by Jeff Johnson
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-28 03:55:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnson 1999-07-08 15:53:39 EDT
The knfsd-1.4.4 package has a separate nfslock initscript
that attempts to start rpc.statd and a new daemon rpc.lockd.

The script fails with the message

Starting NFS lockd:
lockdsvc: Invalid argument
                                                    [FAILED]

presumably because the kernel-2.2.5-22 package does not
enable (or possibly even have) this as a separate service.
Comment 1 Cristian Gafton 1999-07-28 03:55:59 EDT
This is correct, a future release of the kernel rpm will have a patch
that will split lockd in a separate kernel thread that can be fired up
from user space.

I did not have time to get around it yet. :-)

Note You need to log in before you can comment on or make changes to this bug.