Bug 394921 - install with not actually take dotted quad net masks
install with not actually take dotted quad net masks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i586 Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 15:47 EST by Ray Todd Stevens
Modified: 2008-03-11 23:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 23:01:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2007-11-21 15:47:31 EST
Description of problem:

This is really pretty simple.  The installer will not take dotted quadformated
net masks, ie: 255.255.255.224.   Instead you have to enter the address as a
cidr slash style address.

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1.  start an install
2.  say you have a static ip4 address
3.  enter the ip address of the station
4.  Try the enter the net mask as a net mask like the on screen domentation says
you can

No dice.
  
Additional info:

As much as anything this may be a documentation error.   In this day and age I
don't see any reason not to just use the slash notation.   But the
documentation, but the readmes and the on screen documentation says that you can
enter this in the dotted quad format.   You can't.   Frankly I say fix the
documentation not the program.   It is time everyone was using the slash
notation anyway.
Comment 1 David Cantrell 2008-01-03 23:23:26 EST
At what point during installation?  Is it before or after you see "Starting
anaconda, the Fedora installation program..." printed on the console?
Comment 2 Ray Todd Stevens 2008-01-04 09:12:16 EST
Before starting anaconda.

Boot from a rescue cd

there are now several options on the screen select install upgrade ... ie the
first option.

Then you are asked the language and the keyboard to be used.  (English US)

Select install method of http on the next screen

If you have more than one ethernet card you will be asked to choose which one.

then you will see a screen that asks how to configure the ethernet card to be
used.   It will have options for enabling or disabling ip4 and ip6.  The ip4 can
then either be dhcp or manual.   In my case manual is needed as we use static ips.

Now we are to the problem screen.  It is labeled Manual TCP/IP Configuration.  
There are basically four blanks on three lines.   The first line is for the ip
address and the network size indicator.   The second is for the router the third
for the name server.   The problem is with the network size indicator.

According to the on screen and also the on-line documentation this needs to be
entered as a dotted quad.   IE a /27 network entered as a 255.255.255.224.   But
it will not take the entry as documented.   Instead you must enter the network
size as a /27 in this example.

Now as I mentioned above the entire system works great with the entry of a slash
notation network size indicator.   This is the way that the world is going, and
so I see no problem with requiring it be entered this way.   But it should be
consistent.   That is if you are going to require a slash notation network size
indicator, then the documentation should not be telling you to enter this as a
dotted quad.   

So as I said above I would fix the on screen documentation and tell people who
do the on-line documentation, and not try and do a programming fix to match the
documentation.   This is a change from fc4 where you were required to enter this
as a dotted quad and a slash notation would not work.   

I could send a screen picture if needed, but I hope this gets you to the point
you need.

Comment 3 Ray Todd Stevens 2008-02-15 11:15:38 EST
Is this something that should be fixed in fc9.   If so once I figure out how to
play with the alpha I will give it a try.
Comment 4 Ray Todd Stevens 2008-02-16 09:48:33 EST
OK found how to play with fc9.   This is now working properly in fc9 alpha, as
of this date.

Interestingly the fix seems to be to make the net mask format work again.   Oh
well that works too.

Note You need to log in before you can comment on or make changes to this bug.