Bug 394961 - php-magickwand incompatible with php
php-magickwand incompatible with php
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-magickwand (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 16:55 EST by Ryan McKay
Modified: 2008-01-02 20:49 EST (History)
0 users

See Also:
Fixed In Version: 1.0.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 20:32:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan McKay 2007-11-21 16:55:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc7 Firefox/2.0.0.9

Description of problem:
I'm having trouble installing a package on a F7 box. Apache + PHP + several addon php extensions are all working fine, all installed through yum. I installed php-magickwand using:

yum install php-magickwand

It didn't complain and didn't require any additional packages. However when I restart apache to pull in the new library, I get the following error in apache log:
PHP Warning: PHP Startup: magickwand: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=0
PHP compiled with module API=20060613, debug=0, thread-safety=0
These options need to match
in Unknown on line 0

I'm not 100% sure because I haven't seen this problem before, but it seems to be saying that the magickwand library installed by yum was compiled against a different version of php than the one I am running (which was also installed by yum), and is therefore incompatible. 

Version-Release number of selected component (if applicable):
php-magickwand-0.1.8-3.fc6 and php-5.2.4-1.fc7

How reproducible:
Always


Steps to Reproduce:
1. yum install httpd php php-magickwand
2. service httpd start
3. look in apache's error log

Actual Results:
got the error message posted above

Expected Results:
no error message, and php-magickwand lib loaded into php

Additional info:
Here is the yum info output for php and php-magickwand:

Name : php
Arch : x86_64
Version: 5.2.4
Release: 1.fc7
Size : 3.6 M
Repo : installed
Summary: The PHP HTML-embedded scripting language

Description:
PHP is an HTML-embedded scripting language. PHP attempts to make it
easy for developers to write dynamically generated webpages. PHP also
offers built-in database integration for several commercial and
non-commercial database management systems, so writing a
database-enabled webpage with PHP is fairly simple. The most common
use of PHP coding is probably as a replacement for CGI scripts.

The php package contains the module which adds support for the PHP
language to Apache HTTP Server.


Name : php-magickwand
Arch : x86_64
Version: 0.1.8
Release: 3.fc6
Size : 403 k
Repo : installed
Summary: PHP API for ImageMagick

Description:
MagickWand for PHP is a native PHP interface to the new
ImageMagick MagickWand API. It is an almost complete port
of the ImageMagick C API, excluding some X-Server related
functionality, and progress monitoring.
Comment 1 Robert Scheck 2007-12-28 13:54:44 EST
Ryan, thanks for your report and sorry for the long delay. You're absolutely 
right, the package is just broken, because it has to be rebuild for Fedora 7
and the same way for Fedora 8. And as there never was a working package of
php-magickwand, I upgraded to 1.0.1 (F7) and 1.0.5 (F8) to have the latest and
hopefully best. Unfortunately 1.0.5 on F7 isn't possible, as the ImageMagick
on Fedora 7 is not new enough for that.

php-magickwand-1.0.1-1.fc7 Tag: dist-fc7-updates-candidate Status: complete
php-magickwand-1.0.5-1.fc8 Tag: dist-f8-updates-candidate Status: complete
php-magickwand-1.0.5-1.fc9 Tag: dist-f9 Status: complete

Updates are already around the corner:
https://admin.fedoraproject.org/updates/F7/pending/php-magickwand-1.0.1-1.fc7
https://admin.fedoraproject.org/updates/F8/pending/php-magickwand-1.0.5-1.fc8
Comment 2 Fedora Update System 2008-01-02 20:32:10 EST
php-magickwand-1.0.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2008-01-02 20:49:08 EST
php-magickwand-1.0.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.