Bug 395131 - fedora eclipse doesn't show text editor line numbers
fedora eclipse doesn't show text editor line numbers
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-21 20:50 EST by Luis Felipe Marzagao
Modified: 2009-01-09 00:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:18:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Line numbers not showing (50.78 KB, image/png)
2007-11-22 21:04 EST, Luis Felipe Marzagao
no flags Details
Trying to turn line numbers on (58.96 KB, image/png)
2007-11-22 21:04 EST, Luis Felipe Marzagao
no flags Details
SPEC file open erros (21.22 KB, image/png)
2007-11-22 21:05 EST, Luis Felipe Marzagao
no flags Details

  None (edit)
Description Luis Felipe Marzagao 2007-11-21 20:50:38 EST
Description of problem:

Fedora eclipse doesn't show text editor line numbers.

Version-Release number of selected component (if applicable):

Name   : eclipse-platform
Arch   : i386
Epoch  : 1
Version: 3.3.0
Release: 30.fc8

Name   : eclipse-phpeclipse
Arch   : i386
Version: 1.1.8
Release: 16.fc7

[duli@localhost ~]$ java -version
java version "1.6.0_03"
Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode, sharing)


How reproducible:

Turn on "show line numbers" option.

 
Actual results:

Line numbers don't get on.


Expected results:

Line numbers should appear.
Comment 1 Andrew Overholt 2007-11-22 09:21:39 EST
This works for me in both the specfile editor and the java editor.  Is this
perhaps an issue with phpeclipse?  If so, please change the component to
eclipse-phpeclipse.
Comment 2 Luis Felipe Marzagao 2007-11-22 21:04:07 EST
Created attachment 267261 [details]
Line numbers not showing
Comment 3 Luis Felipe Marzagao 2007-11-22 21:04:41 EST
Created attachment 267271 [details]
Trying to turn line numbers on
Comment 4 Luis Felipe Marzagao 2007-11-22 21:05:03 EST
Created attachment 267281 [details]
SPEC file open erros
Comment 5 Luis Felipe Marzagao 2007-11-22 21:08:33 EST
Hello, Andrew: I'm afraid it's not phpeclipse issue. I've tried with C/C++
perspective and the same porblema has occured (please, see att.).

Also, I don't know if it's related, I can' open SPEC files (even though I have
eclipse-rpm-editor package installed). I get these erros:

"An error has occurred. See error log for more details.
java.lang.NullPointerException"

I wonder what the problem is... My Fedora uses pt_BR language... I don't see the
relation, but I don't know. Hope you can help.

Thanks
Comment 6 Luis Felipe Marzagao 2007-11-22 21:10:20 EST
Oh, forgot to say: If I use this version of Eclipse PDT, then line numbers
appear just fine:
http://www.eclipse.org/downloads/download.php?file=/tools/pdt/downloads/drops/R20070917/all-in-one/pdt-all-in-one-1.0-R20070917-linux-gtk.tar.gz

Thanks again.
Comment 7 Andrew Overholt 2007-12-05 10:46:04 EST
Hi Luis,

I'd like to try to narrow this bug down a bit.

First off, PDT and PHPEclipse are different projects.

Please post here the output of:

for f in `rpm -qa | egrep "eclipse|swt"`; do echo $f; rpm -qV $f; done

Also, can you try with a clean workspace (the -data option) and also try with
your ~/.eclipse temporarily moved out of the way?
Comment 8 Luis Felipe Marzagao 2007-12-05 21:26:14 EST
Hello:

>> First off, PDT and PHPEclipse are different projects.

Sure!! I was just making sure it's not something with my java installation.

>> Please post here the output of:
>> for f in `rpm -qa | egrep "eclipse|swt"`; do echo $f; rpm -qV $f; done

[duli@localhost ~]$ for f in `rpm -qa | egrep "eclipse|swt"`; do echo $f; rpm
-qV $f; done
eclipse-phpeclipse-1.1.8-16.fc7
eclipse-cvs-client-3.3.0-30.fc8
eclipse-platform-3.3.0-30.fc8
eclipse-ecj-3.3.0-30.fc8
libswt3-gtk2-3.3.0-30.fc8
icu4j-eclipse-3.6.1-1jpp.3.fc8
eclipse-pde-runtime-3.3.0-30.fc8
eclipse-rcp-3.3.0-30.fc8
tomcat5-jasper-eclipse-5.5.25-1jpp.1.fc8

>> Also, can you try with a clean workspace (the -data option) and also try with
>> your ~/.eclipse temporarily moved out of the way?

Just tried with new workspace, new .eclipse folder and also with a total fresh
F8 install, but no sucess... I get precisely the same results :'(

Thanks


Comment 9 Andrew Overholt 2007-12-06 10:02:14 EST
Hmm.  I don't see how this could be happening.  Your thought about locale could
be  something related.  Can you try with a different locale?  There's also a
3.3.1.1 update in updates-testing.  Can you try that?
Comment 10 Luis Felipe Marzagao 2007-12-08 23:20:51 EST
Hello, Andrew:

No, it's not a locale thing. Just fresh installed Fedora in english, in a VM
machine, no other configs applied. Just did a yum install eclipse-phpeclipse and
tested to see the thing about the line numbers. No success. They are not there,
and you can't turn them on by any means.

Updating eclipse-platform to 3.3.1.1 from updates-testing, though, did solve the
problem. Line numbers are showing and can be turned on or off normally. The text
colors went away...
Comment 11 Andrew Overholt 2007-12-13 16:26:46 EST
Hi Luis,

Try running with -clean and see if that fixes some of your problems.
Comment 12 Luis Felipe Marzagao 2007-12-14 07:47:53 EST
You mean the stable 3.3.0? Unfortunately, no... Exact same thing happening.
Comment 13 Andrew Overholt 2008-01-04 10:07:12 EST
Hmm.  Does a download of an upstream release work?
Comment 14 Luis Felipe Marzagao 2008-01-04 23:12:04 EST
Hello, Andrew: well, updating eclipse-platform to 3.3.1.1 from updates-testing,
did solve the problem, but the text colors went away.
Comment 15 Andrew Overholt 2008-01-06 18:25:04 EST
Hi Luis,

That 3.3.1.1 shouldn't still be in updates-testing.  Does the 3.3.0 update there
work?  Does it introduce any *new* problems?  Does it fix any problems?  Do
these problems still persist with a clean workspace and/or moving ~/.eclipse
temporarily out of the way?  What about after running with -clean?  Can you
reproduce any of this with an upstream (ie. from download.eclipse.org) release?

Thanks,

Andrew
Comment 16 Bug Zapper 2008-11-26 03:38:48 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Bug Zapper 2009-01-09 00:18:39 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.