Bug 395201 - This patch needs to be included in the repo so it can be updated by yum.
This patch needs to be included in the repo so it can be updated by yum.
Product: Fedora
Classification: Fedora
Component: openarena (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michał Bentkowski
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-22 00:01 EST by Scott Griffin
Modified: 2008-06-16 22:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 22:53:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Scott Griffin 2007-11-22 00:01:22 EST
Description of problem:
OpenArena 0.7.1 does not come with the patch listed in the link below, when it
installs you are not able to enter other OpenArena game servers due to
(client/server mismatch basoa "not found"). 
 ### You can download the patch from the following link:

However it needs to be included in the yum repo's so you can perform a update of
OpenArena and have the patch installed. Manually trying to install the patch has
not been successful. 

Version-Release number of selected component (if applicable):
OpenArena 0.7.1 downloaded from using 'yumex' in Fedora 7 and Fedora 8.

How reproducible:

Steps to Reproduce:
1. Install OpenArena
2. Run OpenArena
3. Enter server and you receive error mismatch client/server maps/baseos ect not
Actual results:

Expected results:

Additional info: 
If any further questions are needed please email me at grifs71@yahoo.com - Scott
Comment 1 Scott Griffin 2007-11-22 00:03:15 EST
This also affects Fedora 8 release, I have it installed on several machines and
the patch is not included in the latest release.

Scott Griffin
Comment 2 Michał Bentkowski 2007-11-22 15:59:40 EST
I'm a bit surprise with the things you're writing about. I have
openarena-0.7.1-3.fc8.x86_64 installed and everything works great. Have just
tried to connect to some servers and no server gave me the mismatch error. In
fact - it can't do so because patch you're linking to has been provided by the
package for some time now.
Give me a result of "rpm -q openarena openarena-data" command please.
Comment 3 Scott Griffin 2007-11-22 16:17:23 EST
Here is the results of my query:

[scottg@WEREWOLF ~]$ rpm -q openarena openarena-data

I have tried to install the patch but receive the client/server mismatch I am
not sure if I need to uninstall and reinstall using yumex?

Or if something I did wrong but I installed OpenArena using yumex so it would
get all of the dependencies. 

Comment 4 Michał Bentkowski 2007-11-22 16:27:49 EST
Check then whether file /usr/share/openarena/pak7-patch.pk3 exists. If it does, I'm
afraid I have no idea what's wrong... You could also check if its md5sum is
Comment 5 Scott Griffin 2007-11-22 19:10:08 EST
I will check it out thanks for the quick reply.

Comment 6 Scott Griffin 2007-11-23 10:55:20 EST
This is a common problem with the current version release without the patch.


It is posted on this message board, however downloading the patch in Linux does
not resolve the problem. I am not sure how the patch can be packaged in with the
repo download using yumex or yum. If it was made a dependency it would resolve
itself and not allow installation before the patch was installed.

Comment 7 Michał Bentkowski 2007-11-23 11:24:04 EST
(In reply to comment #6)
> I am not sure how the patch can be packaged in with the
> repo download using yumex or yum.

But the patch _IS_ included in RPM. You can have a look at:

and see that Source4 is oa071-patch.zip - the file you linked to. As it can be seen,
the file has been provided since 13th August 2007.
What's more I've just run openarena and tried to play online. I received no error.

The only thing that comes to my head you can do now is to check if pak7-patch.pk3
exists not only in /usr/share/openarena dir but also in your ~/.openarena/baseoa dir.
It's possible that there's something wrong with the wrapper...
Comment 8 Bug Zapper 2008-05-14 11:06:07 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2008-06-16 22:53:16 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.