This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 395341 - pirut crashes with python exception during detailed package selection
pirut crashes with python exception during detailed package selection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 257241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 03:22 EST by Manuel Traut
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: python-2.5-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 02:14:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manuel Traut 2007-11-22 03:22:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.9) Gecko/20071105 Fedora/2.0.0.9-1.fc7 Firefox/2.0.0.9

Description of problem:
see attached trace

Component: pirut
Summary: TB8bc72d62 gettext.py:313:_parse:AttributeError: 'list' object has no attribute 'split'

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 537, in _optionalPackagesDialog
    d = OptionalPackageSelector(self.ayum, group, pwin, self.getgladefunc)
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 175, in __init__
    self._populate()
  File "/usr/lib/python2.5/site-packages/pirut/GroupSelector.py", line 244, in _populate
    self.pkgstore.append([self.ayum.isPackageInstalled(pkg), listEntryString(po), po])


Version-Release number of selected component (if applicable):
pirut-1.3.26-1.fc7

How reproducible:
Always


Steps to Reproduce:
1. add/remove software (start pirut)
2. optional packages


Actual Results:
exception, pirut quits

Expected Results:
see detailed package selection

Additional info:
Comment 1 Jeremy Katz 2007-11-26 10:59:42 EST
What version of yum do you have installed?  And can you attach the complete
traceback?
Comment 2 Manuel Traut 2007-11-27 02:14:09 EST
issue resolved with packages from testing-repo:
yum-3.2.7
python-2.5-15
pirut-1.3.26-1
Comment 3 Jonathan Earl Brassow 2008-03-26 13:51:19 EDT
*** Bug 257241 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.