Bug 395411 - kernel 2.6.23.1-21 causes limited USB support
kernel 2.6.23.1-21 causes limited USB support
Status: CLOSED DUPLICATE of bug 362221
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 04:31 EST by Fouche du Preez
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 14:22:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fouche du Preez 2007-11-22 04:31:10 EST
Description of problem:
After upgrading kernel to 2.6.23.1-21.fc7 usb support is limited. USB
connectivity no longer works on "advanced" devices such as cameras, only on
"simple" devices such as memory sticks.

Version-Release number of selected component (if applicable):
kernel 2.6.23.1-21.fc7

How reproducible:
always

Steps to Reproduce:
1. upgrade kernel to latest version (kernel 2.6.23.1-21)
2. plug in a camera via usb
  
Actual results:
The following error is returned:
An error occurred in the io-library ('Could not claim the USB device'): Could
not claim interface 0 (Operation not permitted). Make sure no other program or
kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have
read/write access to the device.

Expected results:
Ability to access an "advanced" usb device - in this case a camera to be able to
import photos. PLEASE NOTE: booting up with a previous kernel release e.g
2.6.22.9-91 allows one to use the usb device successfully

Additional info:
I've done the test on 2 machines, both with the same result. In addition I've
also done a bit of google'ling on this and many people seem to have the same
problem after the latest kernel upgrade on various usb devices.

USB functionality is no longer a nice to have feature of an operating system,
please fix this issue asap. Also, please ensure that full usb support becomes
part of the testing cycle to ensure that something like this does not happen
again. Issues like this makes it difficult to use, support and promote a great
linux distribution (which I still feel Fedora is...)
Comment 1 Pavel Rosenboim 2007-11-25 02:10:12 EST
I have same problem.
BTW, F8 kernel (2.6.23.1-49.fc8) does not cause such problem.
Comment 2 Chuck Ebbert 2007-11-26 14:22:33 EST

*** This bug has been marked as a duplicate of 362221 ***

Note You need to log in before you can comment on or make changes to this bug.