Bug 39547 - vfat and staroffice are not friends
vfat and staroffice are not friends
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-08 00:53 EDT by elijah
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-09 22:32:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description elijah 2001-05-08 00:53:09 EDT
Description of Problem:
staroffice and maby other programs have "problems" working with the vfat 
module which shipped with 7.1.  It can no write files and delete folders

How Reproducible:  infinately, happens every time


Steps to Reproduce:
1. mount a vfat filesystem
2. try and access with staroffice
3. 

Actual Results:

Expected Results:


Additional Information:
I have tried the msdos module and there is no problem but short 
filenames.  I know this was working in 7.0 because I still use it that 
way on one computer and I did on the machine I am now having problems on 
then.  A fix or a workaround would be very much so appreciated.  btw I am 
running KDE, not sure if it matters.
Comment 1 Trond Eivind Glomsrxd 2001-05-08 10:29:25 EDT
Description of Distutils:

"A collection of modules to aid in the distribution and installation of
Python modules, extensions, and (ultimately) applications.  A standard
part of Python 1.6 and 2.0, but also distributed separately for use with
Python 1.5.".

This is not remotely distutils related... if this is a bug, and not simply a
permissions problem, it would be kernel-related. However, I believe this would
be caused by your setup - root can read and write files, right? 


Comment 2 Arjan van de Ven 2001-05-08 10:31:56 EDT
Yes, does root have write access ?
Comment 3 elijah 2001-05-08 18:13:23 EDT
root can access the files as can everyone else except from staroffice.   I know 
it is not KDE because it happens when I am not running a windows manager, just 
a terminal to launch staroffice.
Comment 4 Trond Eivind Glomsrxd 2001-05-08 18:15:50 EDT
Are you running Star Office as the root user?
Comment 5 Arjan van de Ven 2001-05-08 18:24:42 EDT
This starts to look like a Staroffice bug
Comment 6 elijah 2001-05-09 07:31:34 EDT
I thought it might be a staroffice bug except that it works with every other 
filesystem I have tried and on vfat on a 7.0 filesystem.
I am running staroffice as root or myself.  Either way it happens.  I do not 
think it is staroffice because I could access vfat filesystems from staroffice 
in 7.0 but not 7.1.
Comment 7 Arjan van de Ven 2001-05-09 07:45:16 EDT
To get things 100% clear: you are able to make files etc on the same
partition from, say, the shell or the KDE filemanager?
Comment 8 elijah 2001-05-09 22:32:07 EDT
yes, I have yet to find another program it does not work with but I can not see 
the differences between the 2.2 and the 2.4 kernel affecting only staroffice in 
this way.
Comment 9 Alan Cox 2001-05-19 16:03:31 EDT
Star Office erroneously assumes it may ftruncate() a file larger than before.
This isnt guaranteed to work and 2.4 vfat legitimately errors it.

So yes - it really is star office, its one of only two apps I know that make
this sssumption blindly (the other is one part of the netscape messenger mailbox
handling)
Comment 10 Harry Jacobson 2001-06-01 00:20:37 EDT
Holy finger pointing! Red Hat! Ain't we all happy? So what if Star Office can't 
be used with vfat in 7.1? It's resolved!
Comment 11 Arjan van de Ven 2001-06-01 05:14:29 EDT
harry@parker.org:
Tell me how I can fix a bug in Star Office and I'll consider it.
Until then there's nothing we can do

Note You need to log in before you can comment on or make changes to this bug.