Bug 395511 - nfsd not stopping for ha-linux heartbeat
nfsd not stopping for ha-linux heartbeat
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 05:50 EST by Adrian Revill
Modified: 2014-06-23 12:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-17 14:47:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Revill 2007-11-22 05:50:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.8) Gecko/20071008 Firefox/2.0.0.8

Description of problem:
When i run /etc/init.d/nfs stop from the command line the nfsd starts and stops ok.

When i use ha-linux heartbeat to control the nfs the nfsd do not stop when told to by the init script.

There seems to be 2 bugs, 
1) The init script returns saying the nfsd has been stopped successfully even when it has not stopped. 
2) The nfsd is not responding to the killproc nfs -2, in Rhel 4.5 the init script did not use -2 and it worked OK

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.start nfs using heartbeat
2.stop nfs using heatbeat
3.

Actual Results:


Expected Results:


Additional info:
Comment 1 Tuomo Soini 2007-12-31 09:01:37 EST
Actually this same bug affect rhel4.6 too. -2 kill option was added on updated
nfs-utils package and it's unable to stop nfsd just like 5.1 version is.

This problem is not only with linux-ha heartbeat. service nfs stop will not stop
nfsd at all!
Comment 4 RHEL Product and Program Management 2009-12-17 14:47:52 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.