Bug 395631 - The Endpoint() postgis function crashes the server
Summary: The Endpoint() postgis function crashes the server
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: postgis
Version: 7
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Devrim GUNDUZ
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-22 12:47 UTC by Kriton Kyrimis
Modified: 2007-12-07 21:34 UTC (History)
0 users

Fixed In Version: 1.3.2-1.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-07 21:34:49 UTC


Attachments (Terms of Use)

Description Kriton Kyrimis 2007-11-22 12:47:00 UTC
Description of problem:
The Endpoint() function crashes the server

Version-Release number of selected component (if applicable):
1.3.1-1.fc7

How reproducible:
Always

Steps to Reproduce:
1.Execute the following query on a database that has postgis enabled. (The
database may be otherwise empty):
select Endpoint('MULTILINESTRING((466684.81980686
4207030.4198318,466632.48982077 4207021.34553892))'::Geometry);

  
Actual results:
server closed the connection unexpectedly
        This probably means the server terminated abnormally
        before or while processing the request.



Expected results:
                  endpoint                  
--------------------------------------------
 0101000000709393F5217B1C41464F1D566B0C5041
(1 row)


Additional info:
This is apparently a known postgis bug, where memory is freed twice. A patch can
be found here:
http://postgis.refractions.net/pipermail/postgis-commits/2007-August/000159.html
I rebuilt postgis using the patch, and it now works as expected.

Comment 1 Devrim GUNDUZ 2007-11-29 07:22:10 UTC
Upstream is about to release 1.3.2, I want to hold this bug until 1.3.2 is
released to avoid frequent updates.

Regards, Devrim

Comment 2 Devrim GUNDUZ 2007-12-07 00:47:19 UTC
1.3.2 was released, and I pushed it for build. Since that patch is now a part of
1.3.2 version, the bug is resolved (I also confirmed on my F-7 installation).

The update will appear in Fedora repos in a few days.

Comment 3 Fedora Update System 2007-12-07 21:34:48 UTC
postgis-1.3.2-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.