Bug 395991 - X31 suspend leaves screen on, fix included in Description
X31 suspend leaves screen on, fix included in Description
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
5.1
i386 Linux
low Severity low
: rc
: ---
Assigned To: Richard Hughes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 13:32 EST by Jan Wildeboer
Modified: 2010-03-30 04:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Wildeboer 2007-11-22 13:32:07 EST
Description of problem:

Suspend on IBM X31 does not switch off screen

Version-Release number of selected component (if applicable):

pm-utils-0.99.3-6.el5.17

How reproducible:

Always

Steps to Reproduce:
1. Install RHEL5.1 on X31
2. Close lid

  
Actual results:

Suspend is activated, screen backlight stays on

Expected results:

screen is switched off.

Additional info:

Can be solved by changing

/usr/share/hal/fdi/information/10freedesktop/20-video-quirk-pm-el5-ibm.fdi

In this file the X31 is not detected correctly, according to hal:

 lshal | grep system.hardware
  system.hardware.uuid = 'E47BD681-46E4-11CB-B1D0-E417DF42D093'  (string)
  system.hardware.serial = '9924KTR'  (string)
  system.hardware.version = 'ThinkPad X31'  (string)
  system.hardware.product = '26725KG'  (string)
  system.hardware.vendor = 'IBM'  (string)
  system.hardware.primary_video.product = 19545  (0x4c59)  (int)
  system.hardware.primary_video.vendor = 4098  (0x1002)  (int)

The prefix *should* be 2672, in the fdi however this prefix is defined as X40/X30.

Whatever.

After changing

      <!-- X40/X30 -->
      <match key="system.hardware.product" prefix="2672">
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
        <merge key="power_management.quirk.radeon_off" type="bool">true</merge>
      </match>

To
      <!-- X40/X30 -->
      <match key="system.hardware.product" prefix="2672">
        <merge key="power_management.quirk.dpms_suspend" type="bool">true</merge>
        <merge key="power_management.quirk.s3_bios" type="bool">true</merge>
        <merge key="power_management.quirk.s3_mode" type="bool">true</merge>
        <merge key="power_management.quirk.radeon_off" type="bool">true</merge>
      </match>

suspend works as intended.

So supposed fix is to add the dpms_suspend quirk to the 2672 prefix
Comment 1 Phil Knirsch 2008-04-11 08:20:28 EDT
Those FDI files are handled by hal itself, so reassigning the bug to hal.
Comment 12 errata-xmlrpc 2010-03-30 04:32:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0256.html

Note You need to log in before you can comment on or make changes to this bug.