Bug 39603 - rp3 applet connects but doesn't think it has
rp3 applet connects but doesn't think it has
Status: CLOSED DUPLICATE of bug 37716
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-08 06:02 EDT by Neil Bird
Modified: 2007-04-18 12:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-12 05:00:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Bird 2001-05-08 06:02:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
The rp3 applet successfully makes a connection (ifup/wvdial), but remains
in 'disconnected' mode (i.e., still says "Click to connect to ...").


How reproducible:
Always

Steps to Reproduce:
1. Click 'Connect' button on rp3 applet.

	

Actual Results:  Dialup succeeds, 'Waiting' dialogue is closed, but rp3
stays in 'disconnected' mode.

Expected Results:  Button changes to 'disconnect from ...', red/green xfer
monitor data are displayed in applet.

Additional info:

I've tried wading through the code, but keep getting lost, I'm afraid.

- this worked painlessly under 6.2 (recently upped to 7.1),
- when run standalone as usernet, the display works fine (!)
- more oddly, if I change the applet prefs. to 'use' another ISP, then
change it back again (all while logged in), it picks up the fact that that
ISP's connected, and sets itself right, displaying comms. data & allowing
'Disconnect'.
Comment 1 Neil Bird 2001-05-09 04:37:47 EDT
Further information: I was wrong about usernet working OK; it's not usernet,
it's running/not running as root.

I run rp3 as a normal user. I tested usernet while I was root and it worked.
I've just run usernet as 'me' and it /didn't/ work in the same was as the
applet. Resetting the prefs. in the applet. got it going as before.
Comment 2 Neil Bird 2001-05-12 05:00:36 EDT
Verification - it only notices it's changed mode (either way, rp3 or usernet)
when run as root; I can't make it 'just' work as any normal user, with or
without any user config.
Comment 3 Bill Nottingham 2001-05-17 15:59:37 EDT

*** This bug has been marked as a duplicate of 37716 ***
Comment 4 Neil Bird 2001-05-19 05:17:57 EDT
Note that the script fix as listed on 37716's solution doesn't fix the problem
of rp3 only working correctly as root. - but it does appear to be initscripts
related as opposed to rp3.

Note You need to log in before you can comment on or make changes to this bug.