Bug 396031 - xorg crashes with error: "module ABI major version (1) doesn't match the server's version (3)"
xorg crashes with error: "module ABI major version (1) doesn't match the ser...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vmware (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 14:08 EST by zekkerj
Modified: 2008-02-12 11:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 11:43:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Port to libpciaccess (23.62 KB, patch)
2007-12-13 18:28 EST, Denis Leroy
no flags Details | Diff

  None (edit)
Description zekkerj 2007-11-22 14:08:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9

Description of problem:
I'm using Fedora 8 in VMware Player. Installation gone very well, but after upgrading with "yum update", X.org doesn't works, crashing with the messages

(EE) module ABI major  version (1) doesn't match the server's version (3)
(EE) Failed to load module "vmware" (module requirement mismatch, 0)
dlopen: /usr/lib/xorg/modules/input//vmmouse_drv.so: undefined symbol: miPointerGetMotionEvents
(EE) Failed to load /usr/lib/modules/input//vmmouse_drv.so
(EE) Failed to load module "vmmouse" (loader failed, 7)
(EE) No drivers available

init (runstate 5) gives me the message below:

INIT: Id "x" respawning too fast: disabled for 5 minutes

Version-Release number of selected component (if applicable):
xorg-x11-drv-vmware-10.15.2-1.fc8

How reproducible:
Didn't try


Steps to Reproduce:
1. Install Fedora 8 in a VM with VMware Player
2. Update system with "yum -y update"
3. Restart system

Actual Results:
The X.org server doesn't loads.

Expected Results:
Normal operation in graphic mode.

Additional info:
Tried to rebuild vmware modules with "VMware Tools", didn't works.
Comment 1 Denis Leroy 2007-12-13 17:47:48 EST
Same here.

The SRPM doesn't compile.
Comment 2 Denis Leroy 2007-12-13 18:28:17 EST
Created attachment 288091 [details]
Port to libpciaccess

This patch from git appears to fix it (port to libpciaccess).
Comment 3 Andrew Farris 2007-12-23 04:59:46 EST
Reporter is it possible you updated to rawhide not just X updates?
The F8 released version is: xorg-x11-drv-vmware-10.15.2-1.fc8.x86_64.rpm
with xorg version: xorg-x11-server-Xorg-1.3.0.0-33.fc8.x86_64.rpm

Updates to F8 now have a new xorg server but not the vmware driver:
xorg-x11-server-Xorg-1.3.0.0-37.fc8.x86_64.rpm

The error:
(EE) module ABI major  version (1) doesn't match the server's version (3)
Only happens for me with Rawhide's version of Xorg, not the F8 version (original
and the updated version both work fine).

In F8 fully updated as of today (fresh install + updates) this driver version
works for me in VMWare Fusion 1.1 on osx 10.5 (with and without the vmware tools).

Using this xorg-x11-drv-vmware with the Rawhide X updates does not work (but
there is no update for this driver yet).

Which VMWare Player version are you using?
Comment 4 zekkerj 2007-12-23 11:00:37 EST
>> Reporter is it possible you updated to rawhide not just X updates?

Don't know. Just did plain "yum update", without any reconfiguration.

>> Which VMWare Player version are you using?
Right now I'm on vacations, so I can't answer you. But I immagine that is the
last version available from vmware, as I recently updated it.

>> In F8 fully updated as of today (fresh install + updates) this driver version
>> works for me in VMWare Fusion 1.1 on osx 10.5 (with and without the vmware
>> tools).
When I come back from vacations I'll try it.
Comment 5 Adam Jackson 2008-02-12 11:43:20 EST
Fixed in xorg-x11-drv-vmware 10.15.2-99.1.fc9, closing.

Note You need to log in before you can comment on or make changes to this bug.