Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 396141 - snmpd spams syslog with _access_interface_entry_save_name and _check_interface_entry_for_updates
snmpd spams syslog with _access_interface_entry_save_name and _check_interfac...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
: 431064 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-22 17:57 EST by Troels Arvin
Modified: 2010-10-22 16:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0376
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:42:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0376 normal SHIPPED_LIVE net-snmp bug fix update 2008-05-20 09:20:48 EDT

  None (edit)
Description Troels Arvin 2007-11-22 17:57:51 EST
Description of problem:
In /var/log/messages, I saw heaps of lines like this:
Nov 22 16:34:02 xen1 snmpd[3865]: netsnmp_assert index == tmp failed
if-mib/data_access/interface.c:467 _access_interface_entry_save_name() 
Nov 22 16:34:02 xen1 snmpd[3865]: netsnmp_assert rc == 0 failed
if-mib/ifTable/ifTable_data_access.c:209 _check_interface_entry_for_updates()

The lines were sent every 30 seconds.

Version-Release number of selected component (if applicable): 5.3.1-19.el5

Steps to Reproduce:
1. Activate the snmpd service.

It may be related to xen. Dell OpenManage has also been installed on the server,
but I doubt that it's related.

Additional info:
I googled around and found this: 
http://sourceforge.net/tracker/index.php?func=detail&aid=1513191&group_id=12694&atid=312694

I tried patching the net-snmp package, adding the mentioned patch (needs to use
-p1 (not -p0) when patching). The patch works. I've seen no bad side effects of
it yet.
Comment 1 RHEL Product and Program Management 2007-11-23 05:04:23 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Jan Safranek 2007-11-23 07:42:13 EST
It's not so simple to fix this assert. It raises when an interface with some
name gets new ifIndex. I.e. when ppp0 gets disconnected (ppp0 goes down) and
user reconnects (ppp0 gets up again, with another ifindex). Net-snmp cannot
distinguish if the new ppp0 is the same interface as old ppp0 (and map
internally the new ifIndex to old ifIndex) or it's new interface, not related to
previous ppp0 (and delete old ppp0 and instantiate new, with new ifIndex).

Both options are valid, it depends on network configuration by admin. The patch
always deletes old interface. Applying the patch could confuse some tools like
MRTG, which do not expect that an interface with certain name gets new ifIndex.

Correct is to make new configuration option, which allows network admin to
configure this behavior - replace old interface or reuse it. Such change is
quite big, please contact your Red Hat support at http://support.redhat.com and
consult with them new RFE.

I agree that the long message is quite annoying and does not say anything
useful, so I will replace it with more meaningful message and display it only
once during net-snmp start.
Comment 9 Jan Safranek 2008-02-01 07:40:27 EST
*** Bug 431064 has been marked as a duplicate of this bug. ***
Comment 12 errata-xmlrpc 2008-05-21 11:42:07 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0376.html

Note You need to log in before you can comment on or make changes to this bug.