Bug 39626 - DHCPD RPM missing file
DHCPD RPM missing file
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-08 08:11 EDT by Allen Barnett
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:36:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen Barnett 2001-05-08 08:11:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Line #20 of /etc/rc.d/init.d/dhcpd expects to find an existing file named
/var/lib/dhcp/dhcpd.leases. However, the RPM package does not either
contain or create such a file, so, you cannot start DHCPD with 'service
dhcpd start' until the file is present. (Since this file is controlled by
the daemon itself, i.e., it is not a user configuration file, I'm not sure
why the init script cares about its existence anyway?)

How reproducible:
Always

Steps to Reproduce:
1. Install dhcp-2.0pl5-4 on a clean system
2. execute 'service dhcpd start'
3.
	

Actual Results:  DHCPD did not start.

Expected Results:  DHCPD should have started.

Additional info:
Comment 1 Michael Schwendt 2001-07-01 21:54:59 EDT
AFAIK, you are expected to configure the daemon properly before starting it.
This includes dhcpd.conf and an initial leases database (whether empty or not).
The package doesn't ship with a default configuration, so no one would manage to
start an incompletely configured dhcpd which might cause network trouble. The
init script checks existence of dhcpd.leases because dhcpd would fail to start
if that file were not present (see man dhcpd.leases).
Comment 2 Allen Barnett 2001-07-02 08:10:53 EDT
OK. The dhcpd.leases man page is quite clear about what your responsibilities 
are for configuring DHCPD.

Please consider this bug closed, then. Thanks.

Note You need to log in before you can comment on or make changes to this bug.