Bug 39645 - tcsh can't handle some german characters
Summary: tcsh can't handle some german characters
Status: CLOSED DUPLICATE of bug 41991
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcsh   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-08 13:39 UTC by Florian Festi
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-08 13:40:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florian Festi 2001-05-08 13:39:57 UTC
Description of Problem:

If pressing some of the german umlaute there is inserted a space character
only. At the second time the space is replaced with the umlaut an der
second Umlaut is inserted, too. Backspace deletes those pairs as if they
would be one character
This Problem is cause only by (in LaTaX syntax) "A, "O, "U "a and "s.
"u and "o is working fine.

How Reproducible:
Every time

Steps to Reproduce:
1.use de-latin1 or de-latin1-nodeadkeys for keymapping
2.use tcsh
3.press some of the keys mentioned above

Actual Results:
umlaut characters are only accepted in pairs

Expected Results:
These characters should be handled as any other

Additional Information:
tcsh-6.10-0.6 does not have this problem. bash works fine and the problem
does not depend on xterm or textconsole. Reading the change log I think it
has something to do with the support for asian characters.

Comment 1 Eido Inoue 2001-06-28 14:37:39 UTC

*** This bug has been marked as a duplicate of 41991 ***


Note You need to log in before you can comment on or make changes to this bug.