Bug 39648 - ntp clients cannot get time from RH71 ntp server
Summary: ntp clients cannot get time from RH71 ntp server
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-08 14:18 UTC by Ivo Clarysse
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-11 17:14:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivo Clarysse 2001-05-08 14:18:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.8.1)
Gecko/20010422

Description of problem:
xntp3/ntp4 clients are not able to query the time from a RH71 system
running 'ntpd'.

How reproducible:
Always

Steps to Reproduce:
On the server:

1. 'rpm -Uvh ntp-4.0.99k-15.i386.rpm' 
2. Add appropriate 'server' lines in '/etc/ntp.conf', dependant on local
network config
3. '/etc/rc.d/init.d/ntp start'
4. Wait for ntpd to synchronize time from its' servers

From another client (tested: RH6.2 xntpd3, RH7.1 ntp4):

5. 'ntpdate <server></server>'  (with <server></server> the IP address of
the server
on which steps 1-4 were performed)
	

Actual Results:  ntpdate responds with: 'no server suitable for
synchronization found'

Expected Results:  Normally, the correct time should appear.

Additional info:

I tried this on 4 different machines, on my office network and my home
network, all with the same result.  If I download, compile and install
ntp-4.0.99k23.tar.gz on the server, it works OK (using identical config files).

Even though 'ntpdate <server></server>' fails, 'ntpq <server></server>' and
'ntpcd <server></server>' from the same client do work.

Comment 1 Harald Hoyer 2001-05-11 10:44:11 UTC
try the server with multicastclient disabled ... took me hours to find out :((


Comment 2 Ivo Clarysse 2001-05-11 17:13:57 UTC
OK, that works for me too.  I can live without multicastclient.


Note You need to log in before you can comment on or make changes to this bug.