Bug 396481 - /sbin/newhidups has been renamed, but the initscript hasn't been updated.
/sbin/newhidups has been renamed, but the initscript hasn't been updated.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 05:54 EST by Bruno Wolff III
Modified: 2007-12-07 03:29 EST (History)
0 users

See Also:
Fixed In Version: 2.2.0-6.1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 17:48:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ups.conf (3.66 KB, text/plain)
2007-12-04 08:56 EST, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2007-11-23 05:54:03 EST
Description of problem:
In Fedora 8 /sbin/newhidups has been replaced by /sbin/usbhid-ups, but the
initscript for the 'ups' service hasn't been updated for that change.

Version-Release number of selected component (if applicable):
2.2.0-3.fc8

How reproducible:
100%

Steps to Reproduce:
1. /sbin/service ups start
2.
3.
  
Actual results:
An error message about not finding /sbin/newhidups .

Expected results:
Successful start of the ups monitor.

Additional info:
I made a sym link from /sbin/newhidups to /sbin/newhidups and things worked as
expected.
Comment 1 Bruno Wolff III 2007-11-25 11:45:33 EST
I noticed some other initscript related issues which you might want to look at
at the same time. The first is that the default /etc/sysconfig/ups file does not
set MODEL which is used by the initscript, in particular for the killproc command.
I set MODEL to upsdrvctl, but I was still seeing another problem. The stop (and
restart) command was not killing off the newhidups process. kill -1 seemed to be
ignored by that process, and if that's the default for the killproc function,
that might be the problem.
Comment 2 Tomas Smetana 2007-11-27 06:38:45 EST
You should not use $MODEL at all.  It's been completely replaced by upsdrvctl. 
You're tight that the initscript must be fixed.
Comment 3 Fedora Update System 2007-11-28 20:37:22 EST
nut-2.2.0-6.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nut'
Comment 4 Bruno Wolff III 2007-11-29 12:42:39 EST
I had already noticed the push to updates-testing. I will for sure test it by
the end of the weekend, though I might get to it late tonight if I am still
awake enough after computing gaming / watching football.
I report back how it works after trying it out.
Comment 5 Bruno Wolff III 2007-11-30 04:41:41 EST
While I am sure I saw an email message about a nut 2.2 update, I am not seeing
it in the updates-testing repository tonight. I'll take another look tomorrow.
Comment 6 Tomas Smetana 2007-11-30 04:54:35 EST
There was discovered a regression in the init script.  I had to unpush the
update and issue another one (it's in pending state).
Comment 7 Bruno Wolff III 2007-12-01 11:36:15 EST
It doesn't look like it got pushed out last night, so it probably won't show up
until Monday now. Is there some place I grab a copy from now? (I have a Fedora
account (CLA only) if that helps.) This isn't critical for me, but I have time
to try it this weekend if you want feedback early.
Comment 8 Tomas Smetana 2007-12-03 03:21:10 EST
The koji build is here if you wish to test:
http://koji.fedoraproject.org/koji/buildinfo?buildID=26031
Comment 9 Fedora Update System 2007-12-03 06:39:01 EST
nut-2.2.0-6.1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nut'
Comment 10 Bruno Wolff III 2007-12-03 19:18:20 EST
I installed 2.2.0-6.1 and tried it out.
It looks like the newhidups error was my fault. That was referred to in a user
part of /etc/ups/ups.conf. I am not sure of a good way to let people know of the
change. Switching the driver name to usbhid-ups fixed the startup.
There is still a problem with shutting the service down. The driver process is
still left running. If I do service ups restart I end up with multiple
usbhid-ups processes running.
Comment 11 Tomas Smetana 2007-12-04 02:21:41 EST
This should not happen -- all the drivers should be terminated by the upsdrvctl
program.  Are you sure that those are not some of the previous instances?  Could
you please attach your ups.conf file, so I may try to reproduce the problem?

Thank you for testing.
Comment 12 Bruno Wolff III 2007-12-04 08:56:44 EST
Created attachment 277021 [details]
ups.conf

I am sure the processes came from the ups service after the update.
I have attached my ups.conf file.
Comment 13 Fedora Update System 2007-12-06 17:48:05 EST
nut-2.2.0-6.1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Bruno Wolff III 2007-12-07 02:55:07 EST
Were you able to duplicate the issue of the driver not being killed when
stopping the ups service?
Comment 15 Tomas Smetana 2007-12-07 03:29:04 EST
No.  I have also an usbhid-ups compatible ups and it works as expected.  I'll
try to investigate this again after I solve more urgent issues.  I have released
a package that works for me.

Note You need to log in before you can comment on or make changes to this bug.