Bug 396841 - pidgin crashes when sending text if sound is enabled
pidgin crashes when sending text if sound is enabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-plugins (Show other bugs)
8
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Eric Moret
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-23 09:50 EST by Brent R Brian
Modified: 2008-10-24 16:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 16:44:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brent R Brian 2007-11-23 09:50:21 EST
Pidgin starts normally and shows buddy list and buddy activity (sign on/off) but
crashes as soon as you press enter after typing a line of text.


How reproducible:
every time

Steps to Reproduce:
1. start pidgin
2. click on buddy
3. type text
4. press enter
5. crash

IBM thinkpad 600e with 196M RAM ... worked fine under F4 - F7, crashes under F8.
 May be related to faulty sound card driver installation see #396101.
Comment 1 Stu Tomlinson 2007-11-23 11:51:51 EST
Please get backtrace as described on http://fedoraproject.org/wiki/StackTraces

Also please tell us what version of Pidgin you are using, and what pidgin or
libpurple plugins you have loaded.
Comment 2 Brent R Brian 2007-11-26 19:16:17 EST
***
*
* DEBUG
*
***

[Detaching after fork from child process 3164.]
W: shm.c: Failed to remove SHM segment /pulse-shm-4207174959: No such file or
directory
[Detaching after fork from child process 3165.]
[New Thread -1283458160 (LWP 3166)]
[New Thread -1293948016 (LWP 3167)]
*** PULSEAUDIO: Unable to create stream.
*** PULSEAUDIO: Unable to create stream.
[Detaching after fork from child process 3169.]
[Detaching after fork from child process 3170.]
[Detaching after fork from child process 3171.]
[Detaching after fork from child process 3172.]
[Detaching after fork from child process 3173.]
[Detaching after fork from child process 3174.]
[Detaching after fork from child process 3175.]
[Detaching after fork from child process 3176.]
pidgin: pcm_pulse.c:115: pulse_stop: Assertion `pcm->stream' failed.

Program received signal SIGABRT, Aborted.
[Switching to Thread -1208973088 (LWP 3136)]
0x00110402 in __kernel_vsyscall ()

I muted the sound and it works fine
Comment 3 Stu Tomlinson 2007-11-26 21:27:51 EST
This looks like it is crashing in pulseaudio, they will likely need a backtrace
with pulseaudio-debuginfo installed to be able to help.
Comment 4 Lennart Poettering 2008-10-24 16:44:19 EDT
This has been fixed a while back in the alsa plugin.

Note You need to log in before you can comment on or make changes to this bug.